[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

login-problems (what: wvdial | perl_error | cupsd | xchat)



Hi list,


Colin Watson wrote:

On Tue, Apr 22, 2003 at 06:41:41PM +0200, Sebastian 'Frank?' Wieseler wrote:
First:
Root can start wvdial but all other users get the error:
$ wvdial
--> WvDial: Internet dialer version 1.53
--> Cannot open /dev/ttyS0: Permission denied
--> Cannot open /dev/ttyS0: Permission denied
--> Cannot open /dev/ttyS0: Permission denied

But all this users belongs to the group tty.
Any idea?

Look at the permissions on /dev/ttyS0. It's typically group dialout, not
tty.


hmm but the users are in that group, too.
However I try to follow the manual from `matt zagrabeln'.
But I think it would work after reading. :-)

Second:
When I start applications or install something I get this message:

Gdk-WARNING **: locale not supported by C library

*or*

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
     LANGUAGE = (unset),
     LC_ALL = (unset),
     LANG = "de_DE@euro"
 are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

What can I do to fit the error-messages?

'dpkg-reconfigure locales' and generate the de_DE@euro locale?


Yeah, you are right. It would work.

Third:
After a short update from the ftp-servers cupsd never starts again.
$ cupsd
cupsd: Child exited with status 127!
$ cupsd -f
cupsd: relocation error: cupsd: undefined symbol: cups_strlcpy

What version of cupsys? You may want to file a bug.


I re-installed cups[d] and then my printer works fine.

And then after the update, too - I can't login on a normal terminal (not X). But it seems so that only the users which has got umlauts or other special signs in their password can't login.

Look in /var/log/auth.log for clues. Again, you may want to file a bug.


Here is my big problem.
I don't know how this file can help me. In this file are only reported my fail logins.
But how can I fix my problem?

I think I need a file - which was modifided by apt-get update - which says the console the encoding.
Do you know such a file?

And I think so, because _only_ the users which umlauts in their password have a problem with the login. So I think that's a problem of encoding or understanding between keyboard and console.
And when I type in my account-name, I see the umlaut-problem.
I have on the console only the english-keyboard driver. Any idea to fix the error?

Fourth:
I use xchat 1.8.9 and everytime when someone type a umlaut - xchat can't display this line correctly. So I think I need to do a update.
But every time when I practise to compile xchat 2.x - I get the message:
Woody:/tmp/xchat-2.0.1# ./configure && make && make install
checking for pkg-config... no
checking for GLIB - version >= 2.0.3... no
*** A new enough version of pkg-config was not found.
*** See http://www.freedesktop.org/software/pkgconfig/
configure: error: "Cannot find glib"

There's a backport of GNOME 2.2 to woody around somewhere.

xchat is gnome? I run it under KDE3. :-/
I _would like_ to run it... :)

But when I install glib - then glib needs a never version of a other paket and when I install that - that needs a other paket - and so on.

(They're called "packages" in English, BTW.)


Sorry. :-(
You are alright. ;)

Yes, GNOME has a good deal
of complex dependencies, which is why the backport needs to exist.

Then I look up on your ftp-server -- what then happens have I already shown -- but there wasn't any newer version of xchat then I have.

xchat 2.0.1 is in unstable.


hmm... okay then I wait till xchat 2.x becomes stable. :-)



Good Night everybody and
thanks `Colin Watson'

Sebastian

P.S.:
Everybody - who has said that I should split this mail - is alright, but I wouldn't increase the traffic of your list.
But I will fix myself. :-)




Reply to: