[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wvdial | perl_error | cupsd | xchat

On Tue, Apr 22, 2003 at 06:41:41PM +0200, Sebastian 'Frank?' Wieseler wrote:
> First:
> Root can start wvdial but all other users get the error:
> $ wvdial
> --> WvDial: Internet dialer version 1.53
> --> Cannot open /dev/ttyS0: Permission denied
> --> Cannot open /dev/ttyS0: Permission denied
> --> Cannot open /dev/ttyS0: Permission denied
> But all this users belongs to the group tty.
> Any idea?

Look at the permissions on /dev/ttyS0. It's typically group dialout, not

> Second:
> When I start applications or install something I get this message:
> Gdk-WARNING **: locale not supported by C library
> *or*
> perl: warning: Setting locale failed.
> perl: warning: Please check that your locale settings:
>       LANGUAGE = (unset),
>       LC_ALL = (unset),
>       LANG = "de_DE@euro"
>   are supported and installed on your system.
> perl: warning: Falling back to the standard locale ("C").
> What can I do to fit the error-messages?

'dpkg-reconfigure locales' and generate the de_DE@euro locale?

> Third:
> After a short update from the ftp-servers cupsd never starts again.
> $ cupsd
> cupsd: Child exited with status 127!
> $ cupsd -f
> cupsd: relocation error: cupsd: undefined symbol: cups_strlcpy

What version of cupsys? You may want to file a bug.

> And then after the update, too - I can't login on a normal terminal (not 
> X). But it seems so that only the users which has got umlauts or other 
> special signs in their password can't login.

Look in /var/log/auth.log for clues. Again, you may want to file a bug.

> Fourth:
> I use xchat 1.8.9 and everytime when someone type a umlaut - xchat can't 
> display this line correctly. So I think I need to do a update.
> But every time when I practise to compile xchat 2.x - I get the message:
> Woody:/tmp/xchat-2.0.1# ./configure && make && make install
> checking for pkg-config... no
> checking for GLIB - version >= 2.0.3... no
> *** A new enough version of pkg-config was not found.
> *** See http://www.freedesktop.org/software/pkgconfig/
> configure: error: "Cannot find glib"

There's a backport of GNOME 2.2 to woody around somewhere.

> But when I install glib - then glib needs a never version of a other 
> paket and when I install that - that needs a other paket - and so on.

(They're called "packages" in English, BTW.) Yes, GNOME has a good deal
of complex dependencies, which is why the backport needs to exist.

> Then I look up on your ftp-server -- what then happens have I already 
> shown -- but there wasn't any newer version of xchat then I have.

xchat 2.0.1 is in unstable.


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: