[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.20 kernel and RTL8139

On Tue, 15 Apr 2003, Rogier Wolff wrote:

> On Tue, Apr 15, 2003 at 02:12:37PM +0200, Alexander Borghgraef wrote:
> >  I'm having a problem getting my on-board NIC to work with the
> >  2.4.20 > kernel. I was using Debian with the old 2.2 kernel, under
> >  which the > network card worked fine. Then I upgraded to the 2.4.20
> >  kernel, and > suddenly I'm unable to connect to the dhcp
> >  server. Using lilo to boot > the old kernel still works fine.
> >  Before you ask, yes I did include the 8139 card in menuconfig. When
> >  > I run ifconfig, eth0 appears in the list alongside lo (loopback
> >  device), > but it doesn't get an IP address like it did in
> >  2.2. Pinging the network > card ( works, but that's lo I
> >  guess? Has anyone had similar > problems, and if so, how do you
> >  solve them?
> Hi Alex,
> Unlike what the others are suggesting, your ethernet card seems to work
> just fine.
> If you used to run 2.2, you're likely to run a dhcpcd that is slightly
> outdated. 2.4 changed something about routing that requires a small
> fix in dhcpcd. You could upgrade dhcpcd.

 Forgive my ignorance, but is dhcpcd the same as dhclient. I tried
'dhcpcd' and 'man dhcpcd', and got nothing. Dhclient is there, but it
times out. Does this mean that I don't even have dhcpcd installed, or
is it just the name of a package dhclient belongs to?

> Or you can do:
> 	route add eth0
> before you start dhcpcd. If I remember correctly that is the
> workaround....

 Same question as above: do I run 'route... && dhclient eth0' or do
I need an actual command 'dhcpcd'? If I get this to work, how do I
get debian to do it at boottime?

In any case, thanks for the info.

Alex Borghgraef

Reply to: