[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.20 kernel and RTL8139

On Tue, Apr 15, 2003 at 02:12:37PM +0200, Alexander Borghgraef wrote:

>  I'm having a problem getting my on-board NIC to work with the
>  2.4.20 > kernel. I was using Debian with the old 2.2 kernel, under
>  which the > network card worked fine. Then I upgraded to the 2.4.20
>  kernel, and > suddenly I'm unable to connect to the dhcp
>  server. Using lilo to boot > the old kernel still works fine.

>  Before you ask, yes I did include the 8139 card in menuconfig. When
>  > I run ifconfig, eth0 appears in the list alongside lo (loopback
>  device), > but it doesn't get an IP address like it did in
>  2.2. Pinging the network > card ( works, but that's lo I
>  guess? Has anyone had similar > problems, and if so, how do you
>  solve them?

Hi Alex,

Unlike what the others are suggesting, your ethernet card seems to work
just fine. 

If you used to run 2.2, you're likely to run a dhcpcd that is slightly
outdated. 2.4 changed something about routing that requires a small
fix in dhcpcd. You could upgrade dhcpcd. 

Or you can do: 

	route add eth0 

before you start dhcpcd. If I remember correctly that is the


** R.E.Wolff@BitWizard.nl ** http://www.BitWizard.nl/ ** +31-15-2600998 **
*-- BitWizard writes Linux device drivers for any device you may have! --*
* The Worlds Ecosystem is a stable system. Stable systems may experience *
* excursions from the stable situation. We are currently in such an      * 
* excursion: The stable situation does not include humans. ***************

Reply to: