[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Orinocco Silver and wep encryption.


I try to get the WEP encryption (sure, it is not secure but better than
nothing) on my wireless card (Orinocco Silver) to work at home. No problem
to use it under Windows, but it doesn't work with Linux.

I have Debian Unstable on my laptop, a recent 2.4.20-ac2 kernel, iwconfig
version 25 and I use the orinoco_cs module which comes with the kerenel.

The accesspoint is from D-Link, but as there are no problems under Windows
there I do not think that the source of the problem lies there.

Dmesg output upon insertion of the card:
hermes.c: 5 Apr 2002 David Gibson <hermes@gibson.dropbear.id.au>
orinoco.c 0.11b (David Gibson <hermes@gibson.dropbear.id.au> and others)
orinoco_cs.c 0.11b (David Gibson <hermes@gibson.dropbear.id.au> and
eth0: Station identity 001f:0001:0008:000a
eth0: Looks like a Lucent/Agere firmware version 8.10
eth0: Ad-hoc demo mode supported
eth0: IEEE standard IBSS ad-hoc mode supported
eth0: WEP supported, 104-bit key
eth0: MAC address 00:02:2D:1B:87:25
eth0: Station name "HERMES I"
eth0: ready
eth0: index 0x01: Vcc 5.0, irq 3, io 0x0180-0x01bf

I tried 64 and 128 bit keys, both without any luck. :-(

If I configure the AP to use the key "qwert" and do on my linux box
"iwconfig eth0 key s:qwert" it works fine (i.e. there are no error
messages) beside that the connection does not work, only the "Rx invalid
crypt" counter keeps increasing.

I tried upgrading the firmware of the card to the most recent version, but
no luck either...

Has anybody got this card working?

Thanxs for any hints/help! :)

- Martin

Reply to: