[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Printer Problems

A further update.  I started double checking everything.  I proofread
mime.convs and mime.types again, then ran dpkg -l|grep -i cups and
started running debsums with the "a" option which I hadn't used before.

debsums -as cupsys
debsums: checksum mismatch cupsys file /etc/cups/cupsd.conf

debsums -as libcupsys2
debsums: checksum mismatch libcupsys2 file /etc/cups/client.conf

Next I tried apt-get --reinstall install cupsys and then repeating
debsums -as cupsys with the same result as above.

What might I do to correct these mismatches?

Tom George

PS  I removed both my printer definitions and re-installed lp with the
CUPS+GIMP-print v4.2.2-pre2 driver.  It still doesn't work from a
terminal - same old error - but I found that I could open the
/etc/cups/ppd/lp.ppd file with mozilla and print it!  I used the
printout to double check against the ppd lines in the last message.

With this workaround I presumably can print any file I want but its awkward.
For example, I can't print a message directly from mutt.

On Thu, Feb 06, 2003 at 09:23:36PM -0500, Jerome Acks Jr wrote:
> On Thu, Feb 06, 2003 at 09:58:31AM -0500, Thomas H. George wrote:
> This latter is the one I use with my Epson 860 without having errors
> you report. 
> > *PPD-Adobe: "4.3"
> > *%PPD file for CUPS/GIMP-print.
> > *%Copyright 1993-2001 by Easy Software Products, All Rights Reserved.
> > *%This PPD file may be freely used and distributed under the terms of
> > *%the GNU GPL.
> > *FormatVersion:	"4.3"
> > *FileVersion:	"4.2.2-pre2"
> > *LanguageVersion: English
> > *LanguageEncoding: ISOLatin1
> > *PCFileName:	"escp2-860.ppd"
> > *Manufacturer:	"EPSON"
> > *Product:	"(GIMP-print v4.2.2-pre2)"
> > *ModelName:     "escp2-860"
> > *ShortNickName: "EPSON Stylus Color 860"
> > *NickName:      "EPSON Stylus Color 860, CUPS+GIMP-print v4.2.2-pre2"
> > *PSVersion:	"(3010.000) 550"
> > *LanguageLevel:	"2"
> > *ColorDevice:	True
> > *DefaultColorSpace: RGB
> *FileSystem:    False
> *LandscapeOrientation: Plus90
> *TTRasterizer:  Type42
> *cupsVersion:   1.1
> *cupsModelNumber: "16"
> *cupsManualCopies: True
> *cupsFilter:    "application/vnd.cups-raster 100 rastertoprinter"
> *cupsFilter:    "application/vnd.cups-command 33 commandtoepson"
> *OpenUI *PageSize: PickOne
> *OrderDependency: 10 AnySetup *PageSize
> *DefaultPageSize: Letter
> etc.
> The error you reported in prior email thread is a typical ghostscript
> error that results if you try to display a nonpostscript file. It
> seems that the cups filter is not converting your text file to
> postscript before passing it to gs-esp. That sound like a mime
> definition problem, but we already checked the cups mime definitions. 
> Just on a lark, do you get the same error with "lpr printtest" and
> "lpr -p printtest"?
> -- 
> Jerome

Reply to: