[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can not get UDMA-100 working...

On Sun, Jan 26, 2003 at 09:21:04PM +0100, Dominique Deleris wrote:
> Hello,
> The background: I have recently bought a new Seagate Barracuda V
> disk (60 Gb), which is UDMA-100 capable. Since my motherboard
> (Asus CUV4X) is only UDMA-66 ready, I have also bought a Promise IDE
> controller (Ultra 133TX2).
> Now the problem: 8 times out of 10, when booting the system, my
> drive is recognized as only UDMA-33! The behaviour is weird: if I
> open the box and slightly move the cable, then after rebooting it
> is OK. But when switching the machine on the day after,
> bang... Back to UDMA-33.

What happens if you use cable ties, tape, string etc to hold the cable
in its 'moved' position and then switch on the day after? Or do you
mean you just jiggle it, and let it settle back to where it was before?

Does it help if you put the Promise card in a different slot?

> I have tried to use a different cable (I was thinking of a cable
> problem) but it hasn't changed anything.

Apologies if this is a dumb question, but have you got the cable the
right way round - blue connector on the motherboard end?

Have you tried a shorter cable? If the Barracuda is the only drive on
the bus, you could get a spare cable and cut it off just beyond the
first drive connector, leaving just that and the blue connector. Use a
good quality set of nippers where the edges of the blades meet
properly, and heavy enough to cut a computer power cord *easily* - not
these miniature so-called "precision" cutters - ribbon cables can be
surprisingly tough. You want to go through quickly and cleanly, to
avoid making "whiskers" on the cut ends which then short-circuit.

> Any ideas/hints?
> I use a vanilla 2.4.20 kernel, in which I have activated the
> Promise PDC202XX support. I have also chosen the "Boot off-board
> chipsets first" option.

Does this kernel driver have any options which you could use to force
a faster UDMA mode? ide0=ata66 works with VIA chipsets but I think
these options have an annoying tendency to be driver-specific.


Reply to: