[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: woody xmms problems

-- Mike Pfleger <pfleger@pfleger-precision.com> wrote
(on Tuesday, 01 October 2002, 12:03 PM -0700):
> * Matthew Weier O'Phinney (matthew@weierophinney.net) wrote:
> >     2. In XMMS, do a CTRL-L (or use the menu to specify a "Location"),
> >     and type "/cdrom"
> > and that's it.
> Do you mean /dev/cdrom, or the mount-point that you'd normally use for
> mounting a data CD?  
In my case, my fstab aliases /cdrom (the mount point) to /dev/cdrom (the
device); I can actually specify either for a location to XMMS and get it
to work.

> If I point it to /dev/cdrom, it figures out all of
> the track information, and the counter runs, as though it were playing
> the CD, but the transport doesn't seem to do anything with the CD, and
> there's nothing but a faint clicking for the first two seconds of any
> track.  
Hmmm... Wierd. It doesn't continue to spin?

> It's SCSI drive, and all of the relevant SCSI modules are 
> loaded into the kernel, and I can mount and access data CDs till the
> cows come home.
The drive I use is mapped via ide-scsi, and this works fine. I'm
wondering... do you have a cable that connects the cd audio output to
the soundcard? 'Cause I think you need this for it to work properly.

Wait, though -- did you say you *could* listen to CDs with OSS, though?
If so, something else is going on... not sure what.

> > What window manager are you using? Does it load a sound system daemon? I
> > ask, because I had problems in KDE at one point on my wife's computer:
> > it was loading artsd, and I didn't have XMMS configured to use artsd --
> > and hence it wouldn't play sound. When she had me switch her to
> > blackbox, XMMS worked fine.
> I'm using fluxbox, so essentially I'm using blackbox, I guess.
I asked simply to see if the WM was loading a sound daemon -- it's not,
if you're using fluxbox.

> > Also, why do you want to use ESD?
> Other applications, like Gaim, want to use ESD, and can't seem to put
> anything out to the real world as audio information.  
Ah. Okay. That makes sense. I use Gaim as well -- but since I don't run
ESD and don't care if there's sound output, I never realized it had

> It seems that ESD
> always worked in the past.  Perhaps it's time to roll a 2.4.x kernel
> and just go the ALSA route?  Does ALSA even support an ES1371 soundcard
> is another question, I suppose...
That's what's on my wife's computer, and I did end up using ALSA. It
wasn't exactly trivial to set up -- and I can't remember right now how I
did it -- but it IS possible!  (said while listening to David Bowie off
her computer...)

Good luck! 

Matthew Weier O'Phinney

Reply to: