[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fonts and XFree86

On Sunday 19 May 2002 23:26, Daniel D Jones wrote:
> On Sun, 2002-05-19 at 15:24, Dale Hair wrote:
> > I believe truetype fonts would not load on mine until I moved the
> > truetype fontpath lines to the beginning of the section.  My X11Config-4
> > is probably not ideal but I'm satisfied with it for now.  I'm open to
> > critique.
> I have my truetypes in /usr/share/fonts/truetype, which is the first
> entry in my fonts list.

That's no problem here. The truetype FontPath is at position 7 down the list. 
But perhaps that behaviour changed between 4.1.0 and 4.2.0.

> > Section "Files"
> > 	RgbPath      "/usr/X11R6/lib/X11/rgb"
> > 	ModulePath   "/usr/X11R6/lib/modules"
> > 	FontPath     "/var/lib/defoma/x-ttcidfont-config.d/dirs/CID"
> > 	FontPath   "/var/lib/defoma/x-ttcidfont-config.d/dirs/TrueType"
> I have deforma installed on my system but there are no font directories
> under /var/lib/defoma.  There are a few *.font-cache files.
> > Section "Module"
> > 	Load  "TrueType"
> > 	Load  "truetype"
> > 	Load  "freetype"
> I have freetype but I don't have either of the [Tt]rue[Tt]ype modules.
> Are they necessary?  Where or in which package are the located?

I don't have them either and it works wonderfully. However (again) I'm running 
4.2.0, but that shouldn't matter all too much since they didn't change that 
part of the system AFAIK. I had 4.1.0 running before and I don't remember 
those modules.

Dumb idea: is the Module secion before or after the Files section? I don't 
know if this matters, but originally it's before.

To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: