[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 3d with nvidia

On Fri, 2002-03-01 at 22:09, David Bellows wrote:
> According to the README you are also supposed to remove the "dri" and 
> "GLcore" options under the Module section.  

I got a couple of additional frames but still. from 13fps to around
15fps now.

I had gtop running at the same time which showed the CPU at around 50%
with X at around 35%.

Here is the relevant part of the updated XF86Config-4 File

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"pex5"
	Load	"record"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
	Load	"xie"

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"nvidia"
	Option 		"NvAGP" "2"
	Option		"NoLogo" "true"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Generic Mouse"

Ive also looked throught the readme and here is the output of

----- Driver Info ----- 
NVRM Version: NVIDIA NVdriver Kernel Module  1.0.2314  Fri Nov 30 19:33:20 PST 2001
Compiled with: gcc version 2.95.4 (Debian prerelease)
------ Card Info ------
Model:        RIVA TNT2 Model 64/Model 64 Pro
IRQ:          11
Video BIOS:
------ AGP Info -------
AGP status:   Enabled
Bridge:       Via Apollo Pro KT133
SBA:          Supported [disabled]
FW:           Supported [disabled]
Rates:        4x 2x 1x  [4x]
Registers:    0x1f000217:0x00000104

What is SBA / FW - Why are they disabled ? Any thoughts.

My system seems to be compliant with other parts of the Readme.

The log file does not flag any warnings / errors with regards to the 
card. Im stumped - any ideas.



Reply to: