[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Voodoo3. DRI, X4.1.0 and Bus mastering <- Still no joy

At 1002229481s since epoch (10/04/01 02:04:41 -0400 UTC), john wrote:

> It's interesting that you say you have DRI working but not bus mastering. Can
> you run setpci on the device and see if bit 3 of word 4 is set? If so my problem
> isn't bus mastering at all.

Here's my output from `glxinfo` (truncated).  As you can see, DRI is on.

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa DRI Voodoo3 20010501 x86/MMX
OpenGL version string: 1.2 Mesa 3.4.2
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_transpose_matrix, GL_EXT_abgr, 
    GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array, GL_EXT_histogram, 
    GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_polygon_offset, 
    GL_EXT_rescale_normal, GL_EXT_stencil_wrap, GL_EXT_texture3D, 
    GL_EXT_texture_env_add, GL_EXT_texture_object, GL_EXT_texture_lod_bias, 
    GL_EXT_vertex_array, GL_HP_occlusion_test, GL_MESA_window_pos, 
    GL_MESA_resize_buffers, GL_NV_texgen_reflection, GL_PGI_misc_hints, 
    GL_SGI_color_matrix, GL_SGI_color_table, GL_SGIS_pixel_texture, 
    GL_SGIS_texture_edge_clamp, GL_SGIX_pixel_texture
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

Here's the output of `lspci -vv` (just for my Voodoo3 card):

01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 
	(rev 01) (prog-if 00 [VGA])

   Subsystem: 3Dfx Interactive, Inc. Voodoo3 AGP

   Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- 
   	    Stepping- SERR- FastB2B-

   Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- 
   	   <TAbort- <MAbort- >SERR- <PERR+

   Interrupt: pin A routed to IRQ 11
   Region 0: Memory at dc000000 (32-bit, non-prefetchable) [size=32M]
   Region 1: Memory at d8000000 (32-bit, prefetchable) [size=32M]
   Region 2: I/O ports at 9c00 [size=256]
   Expansion ROM at dfef0000 [disabled] [size=64K]
   Capabilities: <available only to root>

I think that says that I don't have BusMastering on (That's what the little
minus sign "-" means, right?  I'm not a PCI expert, so you'll have to help
me on this one).  Let me know if I should run {ls,set}pci with different
options to give you better output.

This is a new motherboard, but even on my old crappy motherboard everything
worked the same, so I'm pretty sure that I have it working without bus


Jason Healy    |     jhealy@logn.net
LogN Systems   |   http://www.logn.net/

Reply to: