[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[debian-users] 3Com 3c900 NIC troubles

Hello folks ~

I'm trying to get my 3Com 3c900B-TPO working under Debian 2.2.18pre21.
Here's what I've tried, and what I know, or think I know :P

 - Debian installer didn't detect the card.
 - The card's not detected by Debian at boot (I found no 'eth0' in dmesg)
 - 'ifconfig' lists only "lo" (local loopback?)
 - 'ifconfig eth0 up' gives me "eth0 not found"
 - but 'lspci' shows the card correctly as "02:09.0 Ethernet controller 3com
 - Plug 'n Pray is turned off in BIOS

I tried to use linuxconf to set the 3c59x module, but that failed. It looks
like it created an "/etc/conf.modules" file, which Debian tells me is
deprecated. So no help there. Peripherally, is linuxconf a good thing to use
on Debian? Frankly, I don't know any other way of doing it.

Next, I downloaded 3Com's driver ("3c90x-1.0.0i.tar.gz" version 1.0.0i from
http://support.3com.com/infodeli/tools/nic/linuxdownload.htm) and the
install script says I have the wrong kernel version. So I tried to run the
"compile_UP" script, as the readme suggests, and got PAGES of errors
(further than I can scroll back up). Pointers deferencing and parsers not
parsing all over the place.

Two weeks ago I had a Red Hat 7 installation that detected the card right
off and set it to use the 3c59x module. I don't know if it was the same
version of that module that my Debian install now has. This is not a RH vs.
Debian flame (I formatted the RH disk to install Debian, so you see where my
preference lies), just an observation.

I've done web and usenet searches, to no avail. One person's advice was to
get a different NIC, which is silly. I called 3Com and they said, "Debian? I
dated a girl named Debbie once." Once they realized I was talking about an
OS they told me it was unsupported.

And now I'm pretty much stuck. I'm rather new to all this. All the documents
I've read recently make the process look pretty easy, once you've got the
correct module. I've tried, without success, looking for a pre-compiled
module, but I'm sure I don't know the best places to look.

Any advice? Much appreciated.


P.S. I subscribe to the list, so you can reply there.

Reply to: