[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: anyone have a epson stylus photo 870 working?



On Mon, Mar 05, 2001 at 03:03:17AM +0100, Erdmut Pfeifer wrote:
> 
> maybe we can get that gs-thing solved somehow, before you throw away your
> printer... ;)

that would be nice.

> Actually this gs problem made me curious, however, I was unable to
> reproduce it here, probably due to a different setup.
> Which exact gs command do you use when getting the error? Which version

whatever magicfilter, apsfilter, or lpdomatic from linuxprinting.org
use.  

> of ghostscript? Have you tried it with a non-dummy installation of libsvga,

the one in potato Version: 5.10-10.1

> if so, did it fail too? How did gs crash when compiled without svga
> support? Maybe you could also post an strace of the failing gs command
> (or send it to me privately if you feel that is is too lengthy for the
> list)? 

with real svgalib i get the permissions error with the fake one i get
something like this:

Unrecoverable error: ioerror in .setdevice
Operand stack:
    --nostringval--

Unexpected interpreter error -12.
Error object: (f80)op(379:.setdevice)0x10056274
Operand stack at 0x101b5888:
0x101bcef8: 0x13 devc --Gwrx--- 0x01ec 0x10204128
Execution stack at 0x101b58d8:
0x101be860: 0x0f oper --F---e-- 0x0000 0x1003aaf8 = %interp_exit
0x101be868: 0x03 file --G-rxe-- 0x0001 0x101c2058
0x101be870: 0x0e null --F---e-- 0x0000 0x1003c218
0x101be878: 0x0b int  --F------ 0x0000 0x00000001 = 1
0x101be880: 0x0b int  --F------ 0x0007 0x00000004 = 4
0x101be888: 0x0f oper --F---e-- 0x0000 0x1003c200 = %oparray_pop
0x101be890: 0x05 mpry --G-rxe-- 0x0002 0x101c2e44
0x101be898: 0x05 mpry --G-rxe-- 0x0039 0x101f5bca
Dictionary stack at 0x101b5820:
0x101bf090: 0x02 dict --Gwrx--- 0x5ea8 0x101bf1f8
0x101bf098: 0x02 dict --Gwrx--- 0xf6c0 0x102027e8
0x101bf0a0: 0x02 dict --Lwrx--- 0x597c 0x101c61d8
0x101bf0a8: 0x02 dict --Gwrx--- 0x5ea8 0x101bf1f8

i also get that on my powerpc which has no svgalib. 

here is the relevant portion of strace for the permission error:

stat("/proc/bus/pci", {st_mode=S_IFDIR|0555, st_size=0, ...}) = 0
open("/etc/vga/libvga.config", O_RDONLY) = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=16082, ...}) = 0
read(4, "# Configuration file for svgalib"..., 16082) = 16082
close(4)                                = 0
open("/plato/eb/.svgalibrc", O_RDONLY)  = -1 ENOENT (No such file or directory)
ioperm(0x3b4, 0x2c, 0x1)                = -1 EPERM (Operation not permitted)
write(1, "svgalib: Cannot get I/O permissi"..., 37svgalib: Cannot get I/O permissions.

it shouldn't even be messing with svgalib, its not needed for acting
as a filter.  

> Don't know whether I'll be able to help, but perhaps we could start
> narrowing things down a little...

just for kicks i made gs suid root, which is totally unacceptable for
production, and that made it start printing `your not the owner of
your controlling terminal' or somesuch.  

-- 
Ethan Benson
http://www.alaska.net/~erbenson/

Attachment: pgpgGZ62uM8YO.pgp
Description: PGP signature


Reply to: