[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: more post-upgrade weirdness: debconf

To quote Glenn Becker <glenn@icarus.usanetworks.com>,
# 1) when I run command debconf as root (or non), I get command not

There is no 'debconf' command. The "debconf" package provides various
facilities to packages, but no 'debconf' command.

# 2) when I run man debconf, the system grinds for a bit, spits out some
# those 'dangling symlink' man page warnings, and finally says there is
# man page for debconf. HOWEVER

After you've installed/upgraded many packages, 'man' rebuilds its
database. That's what's happening when your system grinds to a halt.
Very normal. I've also got a number of dangling symlinks in my man dirs.
I'm not too happy about them, but it's no biggie.

# 3) when I apt-get install debconf, the system tells me that debconf is
# already the most recent version, and

Then "debconf" probably is the most recent version :)

# 4) if I try to apt-get remove debconf, I'm told a giant slew of
# are *ALSO* gonna be deleted.

Many packages use "debconf" for various configuration tasks. 'apt-cache
show debconf' for more information.

# 5) update-alternatives --config debconf gives no alternatives for

That makes sense - there's no 'debconf' command. :)

If you're trying to reconfigure a package(which will probably use
services provided by the "debconf" package), you're probably looking for
the 'dpkg --configure <package>' command.

David Barclay Harris, Clan Barclay
    Aut agere, aut mori. (Either action, or death.)

Reply to: