[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

simple network card setup (netgear 10/100 tulip)

I have been reading docs all day but I cannot figure this one out. Note
that I am used to Redhat/Mandrake, and I don't know as much as I would
like to about Debian.

I have a Netgear 10/100 card. I am sure it works, and I have used the
same type of card with other distros. In it's "linux.txt" it describes
an object file called "tulip.o", which I assume to be the same as in the
Debian distro (I am using 2.2). I tried first to do "modprobe tulip" and
I get an error from insmod (I think modprobe is just a higher-level
version of insmod, but I am not sure of this. I tried both) like "device
or resource busy" and then something about how I might try changing the

I have no /dev/eth* devices at all in my system. When I try to load the
tulip module during the initial install I get the same insmod error (but
before it asks for parameters).

I recorded the CDs, so I am not sure of their integrity. I tried copying
files, etc, but it won't be easy to get the good CDs (I think the
downloaded ISOs should be correct) until I have network access.

I half expected Debian to see the card immediately and to work
automatically. I was somewhat surprised to see no eth devices, and more
surprised when I couldn't just load the module to use it.

I added a few modules during the setup, including ip_masq modules and
more notably "traffic shaper". Could these be conflicting? I tried
removing them and inserting the other, but no effect.

Any help would be greatly appreciated. I like Debian so far, but
I haven't seen much :)

    Jeff Davis

Reply to: