[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: simple network card setup (netgear 10/100 tulip)

On Wed, Nov 22, 2000 at 07:43:34AM -0800, Jeff Davis wrote:
> I have a Netgear 10/100 card. I am sure it works, and I have used the
> same type of card with other distros. In it's "linux.txt" it describes
> an object file called "tulip.o", which I assume to be the same as in the
> Debian distro (I am using 2.2). I tried first to do "modprobe tulip" and
> I get an error from insmod (I think modprobe is just a higher-level
> version of insmod, but I am not sure of this. I tried both) like "device
> or resource busy" and then something about how I might try changing the
> parameters.

Hi Jeff, I also use netgear cards.  You may want to try "old_tulip"
instead.  Here is the "Ethernet" section of my kernel config file:
(This is a custom kernel from www.kernel.org so YMMV on some options...)
I also chose to compile it in the kernal, btw.  Oh yeah, kernel is

# CONFIG_LANCE is not set
# CONFIG_RTL8139 is not set
# CONFIG_NET_ISA is not set
# CONFIG_PCNET32 is not set
# CONFIG_AC3200 is not set
# CONFIG_APRICOT is not set
# CONFIG_CS89x0 is not set
# CONFIG_DM9102 is not set
# CONFIG_DE4X5 is not set
# CONFIG_DEC_ELCP is not set
# CONFIG_DGRS is not set
# CONFIG_LNE390 is not set
# CONFIG_NE3210 is not set
# CONFIG_NE2K_PCI is not set
# CONFIG_TLAN is not set
# CONFIG_VIA_RHINE is not set
# CONFIG_SIS900 is not set
# CONFIG_ES3210 is not set
# CONFIG_EPIC100 is not set
# CONFIG_ZNET is not set
# CONFIG_NET_POCKET is not set

In dmesg , I get 
tulip.c:v0.89H 5/23/98 becker@cesdis.gsfc.nasa.gov
eth0: Lite-On 82c168 PNIC at 0xd000, 00 a0 cc 58 67 ea, IRQ 11.
eth0:  MII transceiver found at MDIO address 1, config 3000 status 7829.
eth0:  Advertising 01e1 on PHY 1, previously advertising 01e1.

> I have no /dev/eth* devices at all in my system. When I try to load the
> tulip module during the initial install I get the same insmod error (but
> before it asks for parameters).

This may seem strange, but that is normal .  Try looking in /proc/pci
instead. (:  You should see something like

Non-prefetchable 32 bit memory at 0xd8000000 [0xd8000000].
Bus  0, device  11, function  0:
Ethernet controller: LiteOn LNE100TX (rev 32).
Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master Capable.  Latency=32.  

Hope this helps.... and good luck

My inner child is cranky ---- www.hardradio.com

Reply to: