[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: exim and mtt probs continue

At 08:13 AM 11/18/00, you wrote:
i continue to have problems setting up my email configuration. I have run
eximconfig but have had trouble working out how to answer some of the
questions I am not sure what is meant by some of the terms i.e. what is my
visible mail name. To be honest i have used the default settings to set up
exim i have no idea in most cases whether this is correct. I am dialling up
to my isp using pon, I can't fine where to set up the isp smtp info re
sending mail.

Isn't this one of the last questions eximconfig asks you? Think so.

Fetchmail seems to be ok but where does it write the emails to. I have
installed mutt but when i run it i get the message that there is no
/var/spool/mail/jmj directory jmj being my user name. Apparently exim
should set this up for me/ I am truly at a loss.

I've just spent several evenings puzzling over an identical or similar
problem. The usual location for mailboxes (which are files, not
directories, as I initially thought) is /var/spool/mail. For reasons I
don't understand, the default Debian 2.2 setup makes this a symbolic (I
think symbolic, not hard) link to /var/mail. You see this from

ls -l /var/spool

which shows

mail -> ../mail

at the end of the line for mail. Mailboxes are thus in /var/mail. To see
them do

ls -l /var/mail

The mailbox for some_user should be named and owned by some_user, the group
should be mail, and the permissions should be -rw-rw----. You may have to
create these files using touch, chown, chgrp and chmod to get the ownership
and permissions right. If I remember rightly,

touch some_user
chown new_user new_user
chgrp mail new_user
chmod 660 new_user

will do it.

In my case, I messed up the default configuration and had the same problem
with mutt not seeing my mailbox. Creating the above link and file solved
the problem.

Mutt is also supposed to make a file called .muttrc in my home directory
but this does not exist, apparently without it i cant specify which MTA i
am using.

I don't think you need to specify exim in .muttrc. If I understand
correctly, exim appends incoming mail to user's mailboxes in
/var/spool/mail or, in this case, /var/mail. mutt looks for it in
/var/spool/mail, which is linked to /var/mail. What mutt needs to know is
where to look for the mailbox, not what MTA put the mail there.

Is there a mutt configuration script.  If you have any idea how to proceed.

>>>You probably don't need this to solve your immediate problem. I don't
know of any script, but see the mutt home page for examples of
configuration files. Go to


and more specifically


and perhaps more specifically still the (especially for newbies) link to
Telsa Gwynne's site.

If it would be easier to use another MTA i am happy to do so although i
hear that exim is the best.

>>>Again, this probably isn't your problem, so suggest sticking with exim
for the present. To investigate problems, look at the main exim log file,


using more, less, vi, etc. Initially I had the mailbox locking problem
described in Q0201 of the exim FAQ (http://www.exim.org/FAQ.html). After
creating the link and mailbox files described above this problem stopped.

thanks for your help
 very confused

Hang in there! I'm trying to set up unix style email with
exim/fetchmail/mutt/procmail after many years of Eudora. It isn't coming
easily, in part because documenation, voluminous as it is, doesn't address
all someone new to this setup needs to know. I'm still puzzling out my own


Reply to: