[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I screwed up and cannot boot

At 07:10 PM 3/11/00 +0000, Paul J. Keenan wrote:
> Reinstall time? I have /home on a separate partition.

Maybe not.  I ran into a similar situation (bad superblock errors)
and found that it was because my original rescue disk set couldn't
mount the partitions.

It was solved when I downloaded and created a brand new rescue.bin
and root.bin from frozen and they were able to mount the partitions
no problem.

I booted up, mounted, chroot to run my old binaries, fixed my lilo.conf,
re-ran it et voila.


Well, I'm getting there. Yes, the new rescue and boot disks helped. I was able to mount the partitions, run fsck on them (not while mounted, mind you), and edit /etc/fstab and /etc/lilo.conf. Still there are problems.

Lilo refuses to recognize that I've got any kernels; perhaps they are dead. When I run lilo -D Testing (Testing is the label for my newest kernel) I get that it's not recognized.

The only way I can get a reasonably functioning machine is if I use the new rescue disk, and at the boot prompt type Linux single root=/dev/hda6. An error comes up that I must type in the root password for maintenance, or Control-D to go on. If I type in the password, I've got access to my files (I've pulled off my home directory), but I cannot startx. If I type Control-D, I end in a perpetual loop of cannot find module net-pf-1, at which point I must reboot.

My latest kernel, which I've got on disk, doesn't work. I get kernel panic messages that there is no initd.

Any ideas still? Potato will be out on CD soon so I could reinstall then. I do have my /home. But I feel like I'm almost there.

Thanks again.

Reply to: