[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I screwed up and cannot boot

On Sat, Mar 11, 2000 at 03:45:25AM -0600, David J. Kanter wrote:
> At 07:10 PM 3/11/00 +0000, Paul J. Keenan wrote:
> > > Reinstall time? I have /home on a separate partition.
> >
> >Maybe not.  I ran into a similar situation (bad superblock errors)
> >and found that it was because my original rescue disk set couldn't
> >mount the partitions.
> >
> >It was solved when I downloaded and created a brand new rescue.bin
> >and root.bin from frozen and they were able to mount the partitions
> >no problem.
> >
> >I booted up, mounted, chroot to run my old binaries, fixed my lilo.conf,
> >re-ran it et voila.
> >
> >--
> >Regards,
> >Paul
> Well, I'm getting there. Yes, the new rescue and boot disks helped. I was 
> able to mount the partitions, run fsck on them (not while mounted, mind 
> you), and edit /etc/fstab and /etc/lilo.conf. Still there are problems.

Good call.  fsck on a mounted partition can be ungood.  Sometimes
plusungood, or even doubleplusungood.

> Lilo refuses to recognize that I've got any kernels; perhaps they are dead. 
> When I run lilo -D Testing (Testing is the label for my newest kernel) I 
> get that it's not recognized.

Kernels don't die, they just refuse to pop....

If you can get apt running, try to install a basic kernal package off of
your Debian install disk (you do have one, right?).

> The only way I can get a reasonably functioning machine is if I use the new 
> rescue disk, and at the boot prompt type Linux single root=/dev/hda6. An 
> error comes up that I must type in the root password for maintenance, or 
> Control-D to go on. 

This is standard for "single" mode boot.

> If I type in the password, I've got access to my files 
> (I've pulled off my home directory), but I cannot startx. 

Whoa, Nellie!  One thing at a time.  Let's get your system up and
running before we worry about X windows.

Rather than starting X, you might try doing something useful like
building yourself a working kernel -- install the kernel package from
your installation media, do :

    make mrproper
    make xmenuconfig        # Configures kernel
    make-kpkg --bzimage --revision=Custom_1.0 binary
and install the resulting debs (man make-kpkg for more info).  

> If I type 
> Control-D, I end in a perpetual loop of cannot find module net-pf-1, at 
> which point I must reboot.

Compiling and installing a kernel, with appropriate device support, will
solve this issue.

> My latest kernel, which I've got on disk, doesn't work. I get kernel panic 
> messages that there is no initd.
> Any ideas still? Potato will be out on CD soon so I could reinstall then. I 
> do have my /home. But I feel like I'm almost there.

You're close.  Try a kernel build.  Let us know what happens.

Karsten M. Self (kmself@ix.netcom.com)
    What part of "Gestalt" don't you understand?

Scope out Scoop:  http://scoop.kuro5hin.org/
Nothin' rusty about Kuro5hin:  http://www.kuro5hin.org/

Reply to: