[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kernel modules -- why are they incompatible?

Why are kernel modules incompatible between builds and between versions?
For example, I have a box running 2.0.34 which I don't want to reboot, but
I want to "insmod eql" which wasn't compiled with the kernel. Using the
module from another 2.0.34 box gets me

yodeller# insmod eql
./eql.o: unresolved symbol dev_get_R6bfd1638
./eql.o: unresolved symbol dev_kfree_skb_R9b548e71
./eql.o: unresolved symbol register_netdev_R151649b5
./eql.o: unresolved symbol unregister_netdev_Reac28925
./eql.o: unresolved symbol dev_queue_xmit_R668d85ca

Trying to use precompiled modules packages usually gets the same
response for me (eg ftape). Similarly precompiled modules for one
kernel version never work on another; should/shouldn't they?

Hamish Moffatt VK3TYD              hamish@debian.org, hamish@rising.com.au
Latest Debian packages at ftp://ftp.rising.com.au/pub/hamish. PGP#EFA6B9D5
CCs of replies from mailing lists are welcome.   http://hamish.home.ml.org

Reply to: