[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Problem after Compiling Kernel



Hi;

I posted about this a couple of weeks ago and someone responded with
apossible solution.  But this did not seem to work so here I go again.  I
would really appreciate it if someone could help me out here.

I installed Debian 1.3.1 off the InfoMagic Developers CD.  This release
incorporates the 2.0.29 kernel.  Installation goes without a hitch.
Everything works fine.  I download the latest developers kernel (2.1.71)
and compile it.  Everything seems to compile fine.  Upon reboot with the
new kernel, I get the following error message

SIOADDCRT: Invalid argument

I have determined this to come from the following command which is issued
in /etc/init.d/network.

route add -net ${NETWORK}

Here is what my /etc/init.d/network file looks like


#!      /bin/sh
ifconfig lo 127.0.0.1
route add -net 127.0.0.0
IPADDR=204.69.208.4
NETMASK=255.255.255.0
NETWORK=204.69.208.0
BROADCAST=204.69.208.255
GATEWAY=204.69.208.1
ifconfig eth0 ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}
route add -net ${NETWORK}
[ "${GATEWAY}" ] && route add default gw ${GATEWAY} metric 1


Please note that this exact same file works great with the CD installed
kernel (ie precompiled kernel).  I have tried downloading and compiling
2.0.30 but I get the same error.

Can someone tell me what I am doing wrong?

Regards,
Vaibhav



--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: