[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wtmp problem



At 09:12 PM 26/04/97 +0200, Miquel van Smoorenburg wrote:
>I don't think so. I've seen this behaviour before. The wtmp code
>didn't change between 2.69 and 2.70 - the utmp code did (but very
>slightly, and I still can't find anything wrong with it). Anyway for
>2.71 the new code will be used for utmp in init.
>
>But that won't solve this problem. I think it's just the fact that
>his /var/log/wtmp file is corrupt ie. not a multiple of sizeof(struct utmp).
>There are some rogue programs out there that do not write the 56 bytes
>of the current struct utmp atomically, I think.
>
>Just truncate the wtmp file with cp /dev/null /var/log/wtmp and it
>will start working again.

Hmmmm - if the code doesn't change then can you explain this:-  I just
installed 2.70-1 and started getting corruption on my dialin serial ports.
I go back to 2.69-1 and it's fine - no resetting of the log files, nothing.

If there's something else I can try (yes, I've been through resetting
wtmp/utmp back in March when I first reported it to debian-devel) please
enlighten me :-)

I run mgetty for the dialin lines, I hooked up a vt100 terminal to a serial
port on a different machine with 2.70-1 and used plain getty (well, really
agetty in disguise) and found the exact same thing - if I downgrade, it
works a treat.

Baffling.

--
Karl Ferguson
Tower Networking Pty Ltd   Tel: +61-8-9456-0000     karl@tower.net.au
t/a STAR Online Services   Fax: +61-8-9455-2776     karl@debian.org


--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: