[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

installing debian1.1 in a free partition

Hello everybody

 I'm working with debian-linux v1.1 (I upgrated it the last weekend at 
home a now in my office). All it is working as I expect but I just had to 
solve some minor problems:

* The X configuration: uuuuhh. I run X well when I try startx xinit or
xdm with fvwm. When I used openwin upon xdm was more complicated, but with
some effort now it works (at home I have a new atlantis-intel
motherboard with a AtiMach64 CT chip that ONLY works with the last
XMach64XXXX 3.12D server; after the normal installation of debian on a
clean partition I substituted only the XF86_M64 file in the /usr/X11R6/bin
directory). At the office with a S3 964 video card the installation was
easier from the original debian distribution. The only remaining
problem is that the "Workspace tool" of the openwin doesn't work very well
(do not appear the full menu with all the options; it seems some problem
with the path that I can't solve. 

* info and emacs: the info tool didn't work very well, but I fixed it with 
Guy's script fixdir. Thanks Guy.

* the kernel: Ok, I was very happy when I see that the boot disks have the 
linux 1.3.91 version, but then when I did the installation with dselect I 
didn't see that image package substitute the 1.3.91 version for the older one
1.3.64. Well, that is not trouble because manually I solve it in my 
system. The problem was that neither the 1.3.91 version nor 1.3.64 has 
the NE2000 ethernet card installed. So I return to the 1.3.64 version, 
reconfigure the kernel and reinstalled a new 1.3.64, so it was no 
possible for me to used the newer 1.3.91. It is possible install the NE2000 
card option without recompile the kernel, using some moduleXXX utility 
program? The strange thing is that when I used the debian 0.93R6 version 
I didn't have this problem. 

* using dselect: I am a newer debian user (3 weeks ago I installed the 
0.93R6 version at the first time), so I began the installation 
using the dselect program. It works fine, but I had the following obstacles:
	I grab the debian distribution an put it in a free hard disk 
partition. Then I choose the option:

	 harddisk       Install from a hard disk partition (not yet mounted).

and follow the directions... Ok all was find but then during the 
next installation step , dselect didn't find the directories but showing 
more less the following path foo/foo/foo....//debian/binary
                                       that // I don't understand why appears

Well, I tackled that mounting manually the directory an using 

"mounted        Install from a filesystem which is already mounted" option

* gcc: The gcc compiler is the program that I use more frequently. Always 
is working well, but today, upon the debian1.1 system I found this: my 
main directory is in the old debian0.93R6. The old /home/fdasilva with my 
programs are there. In the new system in other partition, I have the new 
/home/fdasilva and I did a link from the new home folder to the older one

      /home/fdasilva/cprograms -> debianold/home/fdasilva/cprograms
Then I corrected my "Makefile"'s and recompile the code and found that at
the linker step the compiler missing all the files in my precompiled
"library" files. I performed different solutions, and It was only when I
recompiled again the libraries (keeping the same Makefile) with the new
gcc compiler (now is 2.7.2, before was 2.6.3) that old began to work
again. What would be really the problem?. is that symbolic link confusing
the -L mechanism of gcc at compilation time or are the precompiled
libraries *.a keeping some information that I overwrite when I recompiled
and install them in the same places? 


Note: sorry for this long e-mail ;-)

Reply to: