[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Guardar reglas iptables en debian squeeze



El día 7 de mayo de 2011 04:08, Camaleón <noelamac@gmail.com> escribió:
> El Fri, 06 May 2011 16:05:53 -0500, Edgar Vargas escribió:
>
>> El día 6 de mayo de 2011 14:46, Camaleón <noelamac@gmail.com> escribió:
>
>>>> Tal como esta en la wiki
>>>
>>> Sí, todo parece correcto.
>>>
>>> Prueba a cargar las reglas una vez iniciado el equipo:
>>>
>>> iptables-restore < /etc/iptables.test.rules
>>>
>>> Y ejecuta después "iptables -L" para ver qué te dice.
>>
>> Gracias amiga camaleon por responder, eso sería en forma manual y como
>> comprenderás yo deseo que sea automático, pero lo probaré cuando regrese
>> a retomar el servidor;
>
> Sí, eso ya lo sé :-)

Hola :), retmando esto de guardar las regals iptables, en este momento
estoy probando manualmente y funciona, tal como lo hacia desde la
terminal, los clientes del servidor hacen ping a ips publicas, e.g.
ping 8.8.8.8 y otras como 66.102.11.104, asi tengo mis reglas:
root@debian:~# cat /etc/iptable.up.rules
# Generated by iptables-save v1.4.8 on Thu May 19 11:43:23 2011
*filter
:INPUT ACCEPT [6:884]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [3:156]
COMMIT
# Completed on Thu May 19 11:43:23 2011
# Generated by iptables-save v1.4.8 on Thu May 19 11:43:23 2011
*nat
:PREROUTING ACCEPT [2:412]
:POSTROUTING ACCEPT [0:0]
:OUTPUT ACCEPT [3:778]
-A PREROUTING -i eth0 -p tcp -m tcp --dport 80 -j REDIRECT --to-ports 3128
-A POSTROUTING -o eth1 -j MASQUERADE
COMMIT
# Completed on Thu May 19 11:43:23 2011
root@debian:~#

>
> Lo que estoy intentando comprobar es dónde está el error:
>
> a) En la carga del script, que falla

Sigo viendo ese mensaje al iniciar debian, cuando carga todo si
funciona el proxy con sus reglas, pero solo hace ping a la red
192.168.20.4 (ip del router, puerta de enlace) y la red local
(192.168.0.10), esta ruteando, no a otras ips, ya logeado navegando
por internet usando proxy.

> b) En las propias reglas, que tienen algún problema
root@debian:~# iptables-restore < /etc/iptable.up.rules
haciendo manualmente si se logra hacer ping a ips publicas como
deberia ser cuando uno esta conectado a internet, esa es mi duda
amigos, no se que podria estar haciendo mal...

>
> Si cargas las reglas de forma manual y todo funciona correctamente,
> entonces el problema es que al iniciar el equipo no se cargan bien (de
> ahí el error que te aparece al iniciar y que tendrías que revisar con más
> calma).

Eso mismo, pero ahora donde revisar?, en /var/log/messages?, gracias
por su atencion..., si logro cargar correctamente no dudare en avisar
por este medio, saludos...
>
> Si cargas las reglas de forma manual y tienes algún problema (no te
> permite hacer ping al exterior), entonces es que tienes las reglas mal y
> tendrías que revisarlas.
>
>> lo extraño es que al parecer si aplica las reglas
>> porque si hace nat y reenvia, y todas las reglas que le puse a squid,
>> nada mas que es un poco diferente a cuando lo hago manualmente, solo que
>> no hace ping a ips publicas, supongo que todo lo que salga trata de
>> pasarlo al proxy, pero si solo le dije que reenvie peticiones al puerto
>> 80, i don't know :O,
>
> No "adivines", haz las pruebas y extrae conclusiones con los datos en la
> mano ;-)
>
>> amiga camaleon como te decia cuando esta iniciando
>> el sistema me sale en los mensajes de inicio en la ruta donde esta el
>> restore, such file or directory como que no lo encuentra...
>
> Activa el registro del inicio para ver qué es eso... Vete a"/etc/default/
> bootlogd" y pon:
>
> BOOTLOGD_ENABLE=Yes
>
>> Amiga camaleon como guardas las reglas iptables cuando usas ello?
>
> Eso es lo que estamos intentando averiguar, pero primero hay que saber
> qué es lo que está fallando en este caso.
>
> Saludos,
>
> --
> Camaleón
>
>
> --
> To UNSUBSCRIBE, email to debian-user-spanish-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: pan.2011.05.07.09.08.17@gmail.com">http://lists.debian.org/pan.2011.05.07.09.08.17@gmail.com
>
>



-- 
Edguit@r:
http://cybernautape.blogspot.com/


Reply to: