[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Abhängigkeitsproblem



Andreas Pakulat wrote:

> On 16.Mar 2004 - 18:33:37, Markus Raab wrote:
>> Ich würde gerne libsdl-image1.2-dev installieren, welches von
> -dev Pakete benoetigt man i.A. nur fuer das Entwickeln von Software.

Jup, ein Spiel braucht dieses libsdl-image1.2 damit ich es kompilieren
kann. Woody ist leider nicht sehr stark bestückt mit Paketen für
aktuelle Spiele, alles was ich so finde ist immer für unstable...

>> Hier die tatsächlichen Versionen:
>> libpng-dev 1.2.1
>> libpng2-dev 1.0.12
> 
> Das wuerde mich dann aber doch wundern, dann ist naemlich libpng-dev
> nicht i.O. die sollte Version 1.0 irgendwas habe und png2 sollte 1.2
> sein. Hast du das vielleicht verdreht beim Abschreiben?

Nein, libpng2-dev ist die von woody, libpng-dev ist bei irgendeinen
Backport dabei.

>> The following packages will be REMOVED:
>> kdebase-dev kdelibs4-dev kdesdk kspy libarts1-dev libartsc0-dev
>> libpng-dev libqt3-mt-dev qt3-apps-dev qt3-examples
> 
> Ich nehme mal an KDE3.x fuer woody? Und das -dev Paket das du
> installieren willst ist auch fuer woody???

Ja, alles ist für woody. Nur diese libpng-dev Version ist inkompatibel
mit der anderen. Ich suche nach irgendeiner Möglichkeit in den
Dependecies von dem Original libsdl-image1.2-dev Woody Paket
herumzuschrauben und zu sagen, dass libpng-dev Paket geht in Ordnung.
Bei den nicht-dev Paketen gibt es keinen Konflikt, da ist beides
installiert.
Im Prinzip geht es nur um ein paar Headerfiles...

> Hmm, na wenn du nicht grad KDE Programme schreiben/kompilieren willst
> kannst du die Pakete deinstallieren lassen fuers ersten. Geht nichts
> bei kaputt.

Ich schreibe und kompiliere kde Programme, die Idee ist nicht so gut:-)

mfg Markus

-- 
Linux, the choice          | Vernunft, nicht Härte soll die Jugend
of a GNU generation   -o)  | zügeln. - Ratione, non vi vincenda
Kernel 2.4.25          /\  | adulescentia est.  -- Publilius Syrus  
on a i686             _\_v | 



Reply to: