[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [HS] Pb d'adresse IP



François Boisson a écrit :

> Non traceroute montre 30 echos sans réponses, ton modem ne doit pas faire le
> NAT sur le protocole ICMP et ça part dans le paradis des paquets perdus.
ok ok
> 
>>> Rien n'oblige à ce que 82.34.56.78 soit l'adresse LAN du routeur (= la Live
>>> Box) (c'est ce qu'on fait en général) ni même l'adresse IP extérieure.
> 
>> Dans ces cas là où va-t-on piocher l'adresse du routeur ?
> 
> Mettons que la'dresse du routeur soit 1.2.3.4 (IP publique) et que le NAT soit
> fait sur 5.6.7.8 (adresse erronée du cache). Ton IP est 192.168.11.12 et ton
> serveur est 192.168.11.254
> 
> Donc toi tu fais un demande sur 1.2.3.4:80
> 
> * Modem entrant reçoit 1.2.3.4:80, venant de 192.168..11.12
> Il sort un paquet vers 192.168.11.254:80 venant de 5.6.7.8 et fait un liaison 
> 5.6.7.8 <-> 192.168.11.12
> * Serveur 192.168.11.254 reçoit un paquet venant de 5.6.7.8, il répond un
> paquet réponse venant de 192.168.11.254:80 vers 5.6.7.8 donc qui part vers le
> modem.
> * Modem reçoit ce paquet, lié au NAT donc remplace 5.6.7.8 par 192.168.11.12.
> D'autrepart la translation de port fait que 192.168.11.254 est remplacé par
> l'IP extérieure soit 1.2.3.4
> Il renvoit donc un paquet réponse venant de
> 1.2.3.4:80 vers 192.168.11.12
> 
> Tout va bien.
Merci pour ces éclaircissements...
> 
> Par contre pour le ping, (donc le traceroute), pas de translation (car c'est
> n'est pas du TCP) et donc ça disparait. Pas d'échos et des *
Oui bien sûr.
> 
> Voilà comment je vois les choses...
> 
> 
>>> Si j'ai bon, en eteignant et rallumant la live box, ça doit être cohérent
>>> (car on peut imaginer que la live box initialise toutes ses tables)
>> Promis je fais ça dans la journée et je te tiens au courant...
> 
> Je serais déçu si ça ne marche pas 

Je viens de faire le test...Ca marche. L'adresse est maintenant la
bonne...Bravo. Merci encore.

Pascal



Reply to: