[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SLC nfsroot install report (Re: ANN: new boot disks to test)


On Tue, 11 Jan 2000, Ben Collins wrote:

> Ok, at http://xia01.kachinatech.com/~buildd/sparc-2.2.14-potato-boot/current
> you will find the latest set of boot disks.

They work!  Yay!

I installed (sucessfully) on a SparcStation SLC, 16meg ram, no disk, no
floppy, no cdrom, lance network.  Installation was performed using
tftpboot from a x86 slink system, which also serves the temporary
installation nfsroot and the target base system nfsroot.

For the very first time, I've been able to get my SparcStation SLC to boot
Linux.  Until now, it would always crash while booting, every boot image
I've found so far.  Still, it doesn't work flawlessly, as it now hangs
where it used to crash, I have to stop-a and "go" and then it continues
booting.  It happens right after the kernel detects 4 serial ports (AFAIK
the SLC has only two, which share one connector) and right after it
resumes from the break, the kernel detects the keyboard.  Could this be a
submodel problem or a particular hardware problem? (I did once replace a
dead buffer ic on the SLC's mainboard to get the keyboard working at all.)
My prom version is reported a 1.4 on the prom banner.

I got the tftpboot.img in place in /tftpboot, set up rarp entries and
booted the SLC from the net.  It failed to even boot and died with
"Illegal Instruction".

Next, I tried booting from the bare linux-a.out image from the sun4c set.
This time, it booted (with some help as described above.)  

I untarred the root.tar.gz file on the server in /tftpboot/ip.add.re.ss/
(the SLC looks there by default, I noticed from console messages) and
repeated the boot process.  This time, it mounted the installation nfsroot
(readonly) and dbootstrap started (IIRC at some point, there were errors
about /proc/sys/kernel/modprobe not existing.)

I configured the keyboard and got another error: it couldn't create a
file.  The problem turned out to be the fact the root fs was mounted ro.
mount /dev/root / -n -o remount,rw fixed that.  After repeating the
keyboard setup, it seemed to stick (well, not really as it wanted to
configure the keyboard again upon first reboot of the base system.)

Apart from the quirks described below, there were no other big
showstoppers during install and I rebooted the system.  This time I
booted with parameters:
  boot net vmlinux nfsroot=nfs.ser.ver.ip:/export/sparc/nfsroot
And that almost worked (see below.)  After a quick fix and retry it worked
and I had a working system. 

A general note, I really missed the error messages and status messages on
vt3 and vt4.  

On another note, the prom console is S L O W , especially on a SLC.  
Running top on the console takes >75% system resources..  I'm lucky to
have owned a Commodore 64 and to have once been amazed at the speed of the
1541 disk drive.  It made sitting through the install a little more
bearable ;-)

Other problems that I can recall:

The menu selection is slightly off:  there is no reverse video bar, just a
cursor that appears one line too high.  Only the module configuration
dialogs get it right, although it too has quirks, the screen is cleared
twice inbetween screens (takes a long time on my machine, so I noticed
that particularly.)

A problem downloading the kernel and drivers over http.  This was already
mentioned in other messages and will be fixed, so I won't elaborate.

Generally, http proxy failed, because a DNS name resolution is attempted
on the hostname in the url to be requested at the proxy.  I'm behind
(several) firewalls and cannot resolve external hosts.  I had to download
using netscape and put the files on a local http server.

When I first rebooted the new base system, init bailed out because it
could not find /etc/inittab.  Upon inspection on the nfs-server, I found a
file /etc/inittab.real instead.  I renamed it and booted again, it worked.

At boot, kerneld seems to get started, even though I'm running a 2.2
kernel.  Perhaps a /proc problem?

There is no /dev/log, causing syslogd to complain.  Can anybody please
tell me how to create a unix domain socket file from the shell prompt?  I
asked people, looked in manpages, info pages, books, seached the web but
still remain clueless.  

When the system comes up for the first time, I'm prompted with a login:
prompt.  I logged in as root and was presented with the remainder of the
installation procedure.  I think the login: part should be skipped in this
particular situation (I also remember that's how it works on x86 and alpha
installs I've done before.)

The console is somewhat broken.  I cannot start dselect, for example, it
dies with "Error opening terminal: linux".

The default /etc/apt/sources.list uses "stable" urls.  This will break
upon release in the non-us case, because in the to-be-stable potato, the
directory layout is different from still-stable slink.  I noticed this
after I changed the urls to point to unstable trees.

Apt-get works.  But dpkg sometimes fails, I suspect this is related to
out-of-memory situations.  When I run dpkg with a -D22 option, it works
flawlessly, perhaps because the console output makes it go so slow.

> Any one who had problems before, please let me know how these do.

They're great!  At last I can boot Linux on the SLC and I'm pleased that
Debian is the first to get it working.  The whole familiarity of the
installation interface, the Debian GNU/Linux system, apt-get, all that
stuff that I'm used to have on x86 systems, it is all there, on this
pretty ancient (10 yrs old) SparcStation SLC - I'm impressed!



Reply to: