[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debianinstaller root+raid+lvm on U30

On Mon, Jul 11, 2005 at 09:34:52PM +0100, Simon Heywood wrote:
> I've had no end of trouble with SILO and RAID-1.  On my first few
> attempts to install Debian on the Netra, I ran into what I thought was a
> bug in silo.c, and hacking around with it produced varying degrees of
> success.  As far as I can tell, the problem resulted from trying to
> install the boot block for a degraded /boot array (only /dev/sdb1
> active).
> Anyway, using the method I described in my previous post, the SILO
> installation worked fine.  I can boot from disk0:3 or disk1:3, which is
> what I wanted all along (the system can completely survive the loss of
> one disk).
> S.

I manually got a pair of RAID-1 devices and some LVM configured, finally.
I had two small partitions for /boot (sda1/b1 = md0), and two more for
the logical volumes (md1).  I tricked d-i into using them (I honestly
don't even recall now how I did that), and it installed the base system
onto my new filesystems.  Even SILO was quite happy to use the RAID
device; I was able to 'boot disk0' or 'boot disk1' from OBP with
identical results.  However, the new setup absolutely will *not*
complete a boot.

Boot process proceeds until it's time to detect and mount the LV's; I
get dozens of devfs errors:

devfs_mk_dir: invalid argument.<4>devfs_mk_dev: could not append to
parent for /disc

then the system attempts to proceed, seems mostly okay, then init shuts
down my serial console with "/bin/sh: line 1: /dev/pts/0: No such file
or directory".  I have to manually power cycle the box, as it won't even
let me send a break to return to OBP.  Ugh.

I'll try your suggestion next, probably tomorrow.


Reply to: