[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debianinstaller root+raid+lvm on U30


I've been trying unsuccessfully for days now to install Debian onto a
U30 with 2x 9GB Cheetahs using RAID+LVM.  (FWIW, a "normal" install
works fine).  The major problem is that, no matter which version
(stable, testing, testing daily image) of the DebianInstaller I use,
it *refuses* to permit me to create any RAID devices.

According to documentation I've read, one must first create a partition
and mark it as "Linux RAID autodetect"; however, the partitioner has NO
such option available.  All I am presented with are:

	Ext3 journaling file system
	Ext2 file system
	ReiserFS journaling file system
	XFS journaling file system
	FAT16 file system
	FAT32 file system
	swap area
	physical volume for LVM
	do not use the partition

I've even gone so far as to exit to a shell and manually run parted;
the only flags it lets you set are root/boot/lvm.  (On a side note,
why would I be limited to creating RAID devices from partitions?  It's
trivial to use the entire disk, as I'd just done that previously on
another system.)  I've tried creating a partition on each disk and
marking it for LVM, but still no dice.

I've also tried manually creating the RAID and LVM stuff from a shell.
First of course I used mdadm to build the RAID1 device; no trouble
there.  I then returned to the menu to create my LVM volume groups;
it let me select /dev/md/0 and seemed to create my VG
(translation: no obvious error messages).  The installer then
told me there were no volume groups created when I went to create
logical volumes.

I also tried creating all the LVM stuff manually from the shell, but I
get weird results.  After pvcreate /dev/md/0, pvdisplay shows only the
first physical disk from my RAID set.  Undaunted, I then built my volume
group, telling it to use /dev/md/0.  I got back:

	/etc/lvm/backup: fsync failed: Invalid argument
	Volume group "vg00" successfully created

Subseuqently calling vgdisplay returned nothing at all.  (Confirmed by
returning to the installer, which also sees no LVM VG's/LV's).

Any suggestions?  Is root+RAID+LVM just not possible with this installer?
Thanks in advance for any pointers.

[note] Desired layout is both disks as RAID1, with LVM VG on top of
       that; filesystems would be built on the LV's.  I wouldn't be
       against keeping a small boot partition open at the start of
       both disks to make SILO happier, if needed.


Reply to: