[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Circular Dependency libc6 and kernel-image-xx

Far as I was aware, there is a way round this already available that
had been specifically put together.

Testing has a 2.4.26 kernel that can be installed through apt-get
directly on top of woody.  An apt-get dist-upgrade in either sid *or*
sarge will then quite happily install the new libc with no complaints.
 At this point, you can upgrade to 2.4.27.

This has worked for me on a sparc classic and a sparc 5 so far.  From
my searches through the buglists, this kernel version had been built
specially to get round the cyclic dependancy that was ocurring.

On Tue, 16 Nov 2004 17:22:26 +0900, GOTO Masanori <gotom@debian.or.jp> wrote:
> At Mon, 15 Nov 2004 23:14:25 +0100,
> Le grand pinguin wrote:
> > On Mon, Nov 15, 2004 at 07:53:29PM +0100, Hendrik Sattler wrote:
> > > Am Montag, 15. November 2004 11:09 schrieb Le grand pinguin:
> > > > Newer kernels depend on newer kernel tools (modutils, intrd-tools etc.)
> > > > and _these_do_ depend on newer versions of libc6. I had to use 'ar' and
> > > > then a bold tar extraction and dpkg with '--force-depends' to break the
> > > > circle - nothing for the faint of heart.
> > >
> > > File a bug report on libc6. I guess that the runtime kernel version detection
> > > is not the proper way to do this. IIRC, on debian-boot, there was some
> > > discussion on this.
> Please think more before submitting bug report.  If you drop glibc
> runtime kernel detection mechanism, then your system may not be worked
> properly.  But I second the current framework should be improved.
> > Ah, ok, i usually don't llurk on these groups. I'm still not shure what the
> > propper way of handling these things really is. My first question after
> > seeing this was: "iff libc6 really needs a2.4 kernel, will this mean that
> > i should delete my old 2.2 from stable? What happens if i do boot a 2.2?
> > (remember: i was just upgrading - not really the time to dump an old and
> > working kernel without even knowing that the new one will actually work).
> Good question.  Actually, your situation sometimes causes problem.  So
> one idea is: kernel <-> libc ABI check tool in /etc/init.d should be
> warned when depreciated kernel is used.
> This problem is actually serious because this kind of problem affects
> not only sparc but also mips and so on.  initrd-tools depends some
> packages, and such packages also depend on libc6.  But sometimes ABIs
> are changed, and newer libc6 should not be used with the old kernels.
> I currently don't have good idea, but I believe it's not only libc6
> issue but also debian whole mechanism problem.
> Regards,
> -- gotom
> --
> To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: