[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sparc Ultra 10 Potato keyboard setup

    Hi friends,

    First of all, i would like to say thanks to your helpfull e-mails. They put
me on the rigth way to solve my keyboard and mouse problems.
    I already solved the mouse trouble. After a lot of racking, I readed in
Debian-sparc list that a french guy had the same problem and solved it just
removing the GPM program. I did it  and made the sunmouse device again and my
mouse became OK.
    But unfortunately my keyboard is still bad configured, even after a couple
of strugle days of work on it. Following Gabor's tip, a instaled xkeycaps, and
after setup de mouse a was able to try to configure the keyboard. At a first
moment i found out that it was a Sun type 5/PC (because of it lay-out) but the
keys remained unconfigured. The  keyboard test screem of xkeycaps shown that
there were erros on keyboard configuration. So a tryed to configure de
/etc/X11/XF86Config using the Crumley's tip as is writen bellow. In fact, a just
changed de XkbRules to sun, the XkbModel to type5 and the XkbLayout to us. I
din't change the identifier, driver and option corekeyboard because i didn't
find it on file. After change those settings I tryed the xkeycaps test screen
again and the keyboard was correctly identified as type 5/PC keyboards (the
rigth leters appears on test screen as they were pressed on keyboard). So a
saved this configuration and modified the /root/.bashrc file to load
/root/.xmodmap during the login process.  So i though i had solved my problem
but i realized that the keys configurations still remains wrong in the X
enviroment even after the xmodmap file had been loaded during the X Windows load
    I beg your pardon if i am anoying you with these questions but i already
lost a lot of time to solve these problems. I had i Slink on this machine and i
never thougth that Potato install process would be so complicaded. I have been
using Potato on my personal computer at home and i had no any problem with it.
Anymay i'm very disapointed with this Potato Sparc. It seems that Debian people
don't care about testing the OS to these machines.
    Best regards,

    Renato Guedes

Jim Crumley wrote:

> On Wed, Mar 14, 2001 at 10:54:32AM -0300, Renato Braga de Lima Guedes wrote:
> >     Guys,
> >
> >     I had used Debian Slink on my Sun Ultra 10 free of problems, but now
> > I am trying to install the Debian Potato (2.2 r 2)  and i'm having a lot
> > of trouble to configure my mouse and my keyboard to X enviroment.
> >     The keyboard works OK out of the X enviroment, but whem the X is
> > turned on the keyboard seems to change some characters. For example, the
> > character "c" appear when the ENTER key is pressed. I saw, during the
> > instalation process, that  a kind of X-Windows filter program is
> > instaled and a keyboard options screen appear. In fact, I am not sure
> > about wich keyboard select from that list. Since my keyboard is common
> > Sun one (QWERTY with nothing special) I have tried the Suns Keyboad
> > standart options, with no success.
> You need to get the right keyboard set in your XF86Config file.
> If your using XFree 4.x then put the following section in
> your XF86Config file:
> Section "InputDevice"
>         Identifier  "Keyboard0"
>         Driver      "keyboard"
>         Option          "CoreKeyboard"
>         Option          "XkbRules"      "sun"
>         Option          "XkbModel"      "type5"
>         Option          "XkbLayout"     "us"
> EndSection
> (Your keyboard might be a type4 or type6, but I think that Ultra 10s
> usually come with type 5s).  If your using XFree 3.x you'll have to check
> list archives (as someone else suggested) since I don't remember the
> syntax for the config file in that case.
> >     The mouse problem is more challenger because there are few options
> > during the instalation process and I already have tryed all of them. Due
> > to a instalation bug, a had to make the simbolic link from /dev/mouse to
> > /dev/ttyS0 (I tryed to do it to /dev/ttyS1 too) that it's necessary to
> > start the X Windows enviroment, and it was OK, no problems.
> Don't link /dev/mouse to /dev/ttyS0.  On most Suns, the mouse device
> is /dev/sunmouse.
> > But when the
> > X Windows is turned on (the graphical screen appears OK) the mouse
> > pointer does not move. I don't know what to do. This damn mouse worked
> > OK with Slink for almost two years and this problem is becaming very
> > boring. My mouse is a Sun mouse, with 3 butons, and it's connected to
> > keyboard trougthout a rounded conector. The keyboard is connected to
> > computer trougthout a rounded connector too. I suspect that it is a PS/2
> > mouse (due to round conector) but I already have selected this options
> > and things didn't became better. I readed in the Debian.org home page
> > that there are some bug reports about PS/2 mouses but I couldn't find a
> > solution to this problem.
> I think somebody else covered this part.
> Hope this helps.
> --
> Jim Crumley                  |
> crumley@fields.space.umn.edu |
> Work: 612 624-6804 or -0378  |

Reply to: