[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug #602865: please unblock php-net-smtp 1.4.2-2

On Tue, Nov 23, 2010 at 19:02, Thomas Goirand <zigo@debian.org> wrote:
> On 11/21/2010 02:26 AM, Adam D. Barratt wrote:
>> On Sat, 2010-11-20 at 17:48 +0000, Adam D. Barratt wrote:
>>> On Thu, 2010-11-18 at 12:18 +0800, Thomas Goirand wrote:
>>>> The Conflicts: statement will make
>>>> sure that php-pear >= 5.3 is installed before php-net-smtp 1.4.2, which
>>>> is the current issue, while just adding a Depends: will not (there's
>>>> nowhere a document in Debian that tells there is an order in the way
>>>> things are installed if you use a Depends, is it?).
>>> That depends on your definition of "installed".  Policy states that a
>>> package's dependencies will all have been configured before the package
>>> itself is configured, but the problem in this case is at unpack time.
>> As pointed out to me elsewhere, I was being stupid here - policy *does*
>> provide a mechanism for packages to ensure that other packages are
>> unpacked before they are: pre-dependencies.  Either php-net-smtp needs a
>> pre-dependency on php-pear (>= 5.3.1-4 to ensure that the symlink isn't
>> broken) after discussion on debian-devel, or it needs to ensure
>> that /usr/share/php/doc exists in its preinst and create it, pointing at
>> the expected location, if not.
>> I haven't checked each package individually, but a look at squeeze's
>> Contents suggests that php-http-request, php-soap and XML_Parser have
>> the same issue.
>> Regards,
>> Adam
> Adam,
> I am ok to do anything that is required, but I'd need to know what you
> want me to do. Should I reupload php-net-smtp with a Conflicts: which
> was my intention in the first place (the Breaks: was a mistake), or
> should I simply reupload with only a Depends: php-pear (>= 5.3) ?
> I can prepare fixes for php-http-rquest and php-xml-parser too, if
> nobody else is willing to work on them. I have few servers running them,
> and I wouldn't like experiencing upgrade issues. Did you check all php
> PEAR packages in Debian? Is there any chance that there's more packages
> with the issue?
> As for php-soap, this is in the core of PHP5, right?

No, it's not.

> So I guess that
> Ondřej Surý would take care of that? Ondřej, can you confirm that you
> will? Do you need me to write a patch and push it to our Git (it's a
> trivial dependency tweak that we need here...)?

Ondřej Surý <ondrej@sury.org>

Reply to: