[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug #602865: please unblock php-net-smtp 1.4.2-2

On 11/18/2010 05:28 AM, Adam D. Barratt wrote:
> On Wed, 2010-11-17 at 15:55 +0800, Thomas Goirand wrote:
>> * Added a Conflicts: php-pear (<< 5.3), and now depends on php-pear (>=
>> 5.3) because otherwise upgrading path from Lenny is borken (Closes:
>> #602865).
> [...]
>> -Depends: php-pear, php-net-socket (>= 1.0.7), ${misc:Depends}
>> +Depends: php-pear (>= 5.3), php-net-socket (>= 1.0.7), ${misc:Depends}
>> +Breaks: php-pear (<< 5.3)
> Aside from s/Conflicts/Breaks/ in the changelog, why both a versioned
> dependency and a versioned breaks?  The dependency will already ensure
> that an appropriate version of php-pear is installed.
> Regards,
> Adam

Hi Adam and thanks for being reactive on this issue,

The mistake is to write "Breaks:" in the debian/control, because it's at
the file level that there's an issue. So the issue isn't the
debian/changelog. Sorry for that.

As for this issue, I really think a Conflicts: is needed, as there will
be an issue if php-pear is installed. The Conflicts: statement will make
sure that php-pear >= 5.3 is installed before php-net-smtp 1.4.2, which
is the current issue, while just adding a Depends: will not (there's
nowhere a document in Debian that tells there is an order in the way
things are installed if you use a Depends, is it?).

So, what do you think Adam? Should I re-upload with Conflicts: instead
of Breaks: in debian/control? What's the next course of action that you
would recommend here?


Reply to: