[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GNUstep libraries soname bump

Yavor Doganov wrote:
Adeodato Simó wrote:
(BTW, the GNUstep transition is also tied to the
libpoppler3->libpoppler4 transition via popplerkit.framework.)
No, it is not, at least not as far as my SQL-fu can see. libpopplerkit0
does not depend in any of the renamed libraries in the GNUstep transition, so it's free to migrate at will.

You are right that it doesn't depend on the GNUstep core libraries,
but it should.  See
http://lists.debian.org/debian-release/2008/07/msg00068.html for some
explanation.  (Yes, these are bugs, IMVHO RC as per Policy 8.6.)

Or do you know more about this than the Packages.gz files do? :-)

The other packages in this situation are gnustep-netclasses and
pantomime1.2.  If they don't get rebuilt, their reverse dependencies
(gnumail.app, lusernet.app, talksoup.app, viewpdf.app, etc.) will fail

likewise with renaissance (zipper.app) and gorm.app (and gnustep-dl2)


Reply to: