[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [alpha, hppa] GCC-4.3 as the default compilers for lenny?

On Mon, Mar 24, 2008 at 10:36:46AM +0100, Pierre Habouzit wrote:
>   But unlike others that doesn't seems to care a lot about which
> compiler is default in lenny, I would be sad to not see gcc-4.3 our
> default compiler. It comes with a lot of enhanced warnings and error
> checking, that I've seen in action, and hence know to be worthwhile (the
> array bound checking e.g. is really nice). And the g++ strictness wrt
> headers is important to have, else code developed on Debian would need
> porting to work on other distributions. I believe Debian to be an
> excellent development platform, and we should not lag behind wrt stable
> development tools.

I mostly have a problem with the default gcc being behind on i386/amd64.
Most of our maintainers and users will be using that.  Things might for
instance be broken with gcc 4.3 and nobody notices it.


Reply to: