[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [alpha, hppa] GCC-4.3 as the default compilers for lenny?



On Sun, Mar 23, 2008 at 07:15:11AM +0000, Mike Hommey wrote:
> On Sat, Mar 22, 2008 at 10:02:22PM +0100, Matthias Klose wrote:
> > Matthias Klose writes:
> > > For all ports besides alpha and hppa we plan to make GCC-4.3 the
> > > default compilers for lenny.
> > 
> > amd64 and i386 side note: the gcc-4.3 4.3.0-2 upload has a patch
> > reenabling the cld instruction when stringops are used; this patch is
> > neither in the gcc-4_3-branch or in the trunk.  I will revert this
> > patch once a fixed kernel is found in testing and there's no patch
> > applied in the upstream sources to avoid shipping a GCC which differs
> > in code generation from upstream. 
> 
> Isn't it risky for partial upgrades from etch ? Shouldn't we wait for
> lenny+1 to revert this ?

  I second that, please don't revert the patch until lenny+1. FWIW I
believe the release team as a whole wanted the patch to be kept as well,
but I'll let the other members correct me if I'm wrong.

-- 
·O·  Pierre Habouzit
··O                                                madcoder@debian.org
OOO                                                http://www.madism.org

Attachment: pgp18klwTDm7a.pgp
Description: PGP signature


Reply to: