[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse doesn't work on iBook G4 after sleep in Sid

On Fri, Mar 28, 2008 at 09:54:15AM +0100, Francesco Pedrini wrote:
> On Tuesday 25 March 2008, Denís Fernández Cabrera wrote:
> > Hello,
> >
> > I dist-upgraded, last weekend, to the lastest version of Sid on the
> > repositories for my iBook G4 (summer 2005). Generally, it works very
> > well (it did fix several bugs that I was suffering till now), but I
> > mouse support after suspension doesn't.
> >
> > After suspending the system (e.g. by closing the lid) it resumes
> > correctly, but the mouse is useless. It won't move or receive any
> > clicks, and restarting X doesn't help. I have to do a full system
> > restart for the mouse to work again.

I also see this occasionally. It does not happen on every suspend/resume
cycle. But for me it's always enogh to just rmmod and modprobe
appletouch. Just switch to a text console with ctrl-alt-f1, login as
root and type "rmmod appletouch ; modprobe appletouch".

My machine is a powerbook5,8 and I'm using 2.6.25-rc7 (self compiled).


> >
> > I'd like to fix this issue because it is quite important, since not
> > even restarting the X will help. Perhaps it is a matter of modules
> > that don't get reloaded after suspension?
> There is an opened bug on this [1], but nothing seems to move.
> I've the same problem and it is really annoying have to poweroff the 
> laptop even for the few minutes needed to move from a place to 
> another...
> I've investigated a bit with google, and i was able to find a change in 
> the appletouch driver relative to the 'Geyser mode' [2], but i don't 
> know if that change is the responsible of the bug.
> Unfortunately i don't have the time to investigate with git bisect.
> I've also tried the 2.6.25 from the kernel-team repository and the bug 
> is still there...
> I hope that Johannes Berg is reading us and can fix it soon ;))
> (Johannes, thanks for your work, really ;))
> Regards,
> Francesco
> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=465278
> [2] 
> http://www.linuxhq.com/kernel/v2.6/24/drivers/input/mouse/appletouch.c
> -- 
> :wq

Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~

Reply to: