[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: no sound - iBook G3

On 8/8/07, Johannes Berg <johannes@sipsolutions.net> wrote:
> On Wed, 2007-08-08 at 12:23 +0200, Andrzej Mendel wrote:
> > I guess that snd-aoa could be the module that you need to load in order
> > to get sound on your machine. I'm not sure if it covers yours, but it is
> > supposed to obsolete snd-powermac, so if your iBook is supported by
> > snd-aoa then you'll have better luck trying it out. Perhaps Johannes
> > Berg can shed some light on this subject.
> I don't usually read debian-powerpc closely so you'd better CC me if you
> want me to shed light on anything :)
> That said, if snd-powermac creates a master volume control in alsa then
> it's the one to use and not snd-aoa; but I don't know what is going
> wrong with it.

Just for the info, in case it helps diagnose something.

When I first installed Etch my gnome volume icon was on mute and could
not be changed. I then added snd-powermac to my modules and the icon
worked (which I assume is what you are refering to as the master
volume control in alsa). With this setup I thought sound was working,
but when I ran Amarok it said that xine could not find a sound driver.
That's when I posted to the list and it was recommended that I run
alsaconf, which seemed to load a driver for powermac sound. Anyways,
sound seems to be working now, I can run Amarok and listen to music so
I'm happy. Thanks for the help.

> johannes

Reply to: