[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unable to boot Motorola Powerstack II

Am Dienstag, 2. Januar 2007 09:56 schrieb Sven Luther:
> Last post here except one, due to my self-imposed ban asked by Fabio's
> mediation attempt.

Let's hope this will be sorted out in a way that's acceptable to all parties 

> Normally the installer should have done prep-install, and not nobootloader,
> so i am wondering what happened here, 

After booting the image from tftp, the system goes straight into that mode 
without giving me any options, except for language, keyboard layout and 
manual or guided partitioning.

> can you provide the /proc/cpuinfo of your machine ?

Here we go:

processor            : 0
cpu                     : 604r
clock                   : ???
revision               : 49.2 (pvr 0009 3102)
bogomips             : 299.9
machine              : PReP Utah (Powerstack II Pro4000)
l2cache               : 512 KiB, parity disabled, synchronous, pipelined, no

> When you do the installation, can you go to console 2, and check with
> parted /dev/sda that you have indeed a prep partition.

I do not have /dev/sd* devices, they are named 

/dev/scsi/bus0/<long path>/part1, then part2 and so on. 

When partitioning manually, I declared the first partition "PReP", bootable, 
no mountpoint, and the partitioner confirmed that. Seems to be OK.

2nd partition is swap, 3rd is /.

> Then before rebooting, you go to console 2 again, and you check that the
> vmlinuz kernel has indeed been created 

It's located at /boot/vmlinux . Should it be under root?

>   dd if=/target/boot/vmlinuz-2.6.18-3-prep of=/dev/sda1

Done, seemed to work (no weird ouputs at least).


boot /pci/scsi@2/disk@0,0:1 (:1 being the PReP boot partition)

does not work. 

boot /pci/scsi@2/disk@0,0 or
boot /pci/scsi@2/disk@0,0:3

do not work, either.

> Please consider filing a bug report against d-i about the fact that
> prep-installer is not being run on your box, including the /proc/cpuinfo
> output.

Is there a chance that this will be fixed? I did not follow the development, 
but this platform seems to be discontinued.


Reply to: