[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Assign Apple Keys = CTRL



Hi Andreas,

Andreas Wuest wrote:
Hi Brian

On 8/12/05, Brian C <brianwc@berkeley.edu> wrote:

I want the two "Apple" keys on my powerbook to simply be extra CTRL
keys. I've tried to do this a couple different ways, but it's never
worked. Anyone know how to do this? (Explain step-by-step!) Thanks.

1. $ xev
 1.1. move mouse pointer into xev window
 1.2. press the left 'ctrl' key
 1.3. note the key_sym_ (the name, not its hexadecimal representation)
of the last event in the console output (KEYSYM_CTRLL)
 1.4. press the right 'ctrl' key
 1.5. see step 1.3 (KEYSYM_CTRLR)
 1.6. press the left 'apple' key
 1.7. note the key_code_ (the decimal value, not its string
representation) of the last event in the console output
(KEYCODE_APPLEL)
 1.8. press the right 'apple' key
 1.9. see step 1.7 (KEYCODE_APPLER)

2.  $ man xmodmap
 2.1. read it
 2.2. create a file ".Xmodmap" with the two entries
        keycode KEYCODE_APPLEL = KEYSYM_CTRLL
        keycode KEYCODE_APPLER = KEYSYM_CTRLR
   substituting the names in CAPITAL by the values noted during step 1.

3. read http://lists.debian.org/debian-powerpc/2003/08/msg00195.html
starting from the line "Ok, just for the records.. The debian way(tm)
to invoke xmodmap:".


I followed these instructions. However, I am using gdm and Gnome and now when Gnome loads I get a message saying, "You have a keyboard remapping file (.Xmodmap) in your home directory whose contents will now be ignored."

There is a long thread about this problem here:
http://lists.debian.org/debian-gtk-gnome/2004/07/msg00045.html

but one person reports adding some script works while another says it doesn't. From what I could tell, the thread never reaches a definite conclusion on how to solve this problem. Anyone know how to force Gnome and gdm to accept one's modified keymap?

Also, I tried this command as root to temporarily get the right mapping:

xmodmap -e "keycode 115 = Control_L"

and then even though xev shows the same output for CTRL and "Apple" keys the "Apple" key still doesn't actually behave like CTRL, for instance, you cannot copy and paste with it. What's going on there?

Brian



Reply to: