[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Auctex on iBook fails (same version works on x86)

On Fri, 04 Feb 2005 16:13:47 +0100
David Kastrup <dak@gnu.org> wrote:

DK> [Copy by mail since I don't know whether posting to the Usenet
DK> mirror will propagate back to the list]
DK> James Tappin <sjt@star.sr.bham.ac.uk> writes:
DK> > I've got the auctex package (advanced tex/latex mode for emacs) on
DK> > several boxes and it works just fine on the x86 boxes but on my
DK> > iBook it fails with the error:
DK> > File mode specification error: (error "Lisp nesting exceeds
DK> > max-lisp-eval-depth")
DK> >
DK> Suspect #1: emacspeak-17.  Suspect #2: conflicting remains of a
DK> previous manual AUCTeX installation.
DK> In either case
DK> M-x list-load-path-shadows RET
DK> should give you a clue about the problem.

list-load-path-shadows only showed shadowing of the .el files by the
.elc files.

#1 never installed
#2 possible but a purging auctex and then removing everything that was
#left didn't help.

I eventually managed to fix it by purging auctex and  emacs21*. Then
moving everything left in the /usr/share/emacs/site-lisp to a temporary
location and reinstalling, moving back any of the site-lisp stuff that
was demanded by the emacs installation.

Still a bit puzzled but at least operational. 

Thanks for the pointers.


| James Tappin           | School of Physics & Astronomy |  O__    |
| sjt@star.sr.bham.ac.uk | University of Birmingham      | --  \/` |
| Ph: 0121-414-6462. Fax: 0121-414-3722                  |         |

Reply to: