[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian ppc64

On Wed, 2004-12-08 at 10:23 -0200, Rafael Espíndola wrote:
> On Wed, 8 Dec 2004 12:44:47 +0100, Andreas Jochens <aj@andaco.de> wrote:
> > On 04-Dec-08 11:34, Sven Luther wrote:
> > I have prepared a patch for the glibc package which makes glibc compile
> > and work for ppc64. The patch can be found at
> > 
> > http://debian-ppc64.alioth.debian.org/gcc4/patches/glibc_2.3.2.ds1-
> > 
> > The patch creates a large 22 MB file
> > 
> > 'debian/patches/10_cvs20041202.dpatch'
> > 
> > with the diff between glibc-2.3.2 and the current glibc CVS version
> > as well as a list of Debian patches 'debian/patches/00list.ppc64' which
> > still have to be applied to the current CVS glibc. This '00list.ppc64'
> > is used _instead_ of the normal '00list' for ppc64. The rest of the
> > patch basically adds 'ppc64' at the appropriate places. Please note that
> > this patch is work in progress. It is only two days old and it will
> > likely need some changes.
> I was using gcc-3.4 and a much smaller (attached) patch was enough to
> build it. I agree that it is better to upgrade llibc but a simple
> patch can be merged first.
> Is there some big problem the in current debian glibc that I haven't hit?

Appart that it's completely outdated, doesn't support TLS and NPTL on
ppc32, probably doesn't support altivec in contexts, etc... well ...


Reply to: