[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: swsusp/pmdisk status on ppc?

> See my post to this list with my current patch for 2.6.5-rc3-ben0. Might
> also apply to 2.6.5-linus with minimal fuss.

yep, it applied.

I tried to remove all loaded modules, but I couldn't make some of them
unused (from memory, about these (numbers wrong since this has been
copied laster):

    ds                     23784  2 
    pcmcia_core            72708  2 ds,yenta_socket
    snd_powermac           44900  2 
    i2c_core               27508  1 snd_powermac
    snd_pcm_oss            69348  1 
    snd_pcm               121756  2 snd_powermac,snd_pcm_oss
    snd_page_alloc         13452  1 snd_pcm
    snd_timer              29436  1 snd_pcm
    snd_mixer_oss          23456  2 snd_pcm_oss
    snd                    65460  5 snd_powermac,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
    soundcore              12168  3 snd

) and so just did echo -n disk > /sys/power/state (with X running). It
worked, and came back again and restored everything fine, except for one
or two things:

- sound broke: clicking on wmmixer made everything (at least X, mouse
movements) freeze for about 2 seconds each time. xmms said it couldn't
open the device.
  Well, if I only could find out what's keeping alsa active, I would
try with modules removed. But I did lsof|grep /dev/snd and it didn't
show anything.

- after starting /etc/init.d/usbmgr again, the button of the trackpad
stopped working (moving the pointer with the trackpad still worked,
and clicking and moving with the usb mouse did work, too).

Any ideas?

(I'm also wondering if mol works, haven't tried yet. Well, there will
probably be at least one issue: I currently have two swaps of 262136 k
each, and it looks like I can only use one of them for pmdisk/swsusp,
and mol is taking up almost 200M, so space will probably become too
narrow. Will I really have to repartition?)

Thanks to you and ben for the great work

Reply to: