[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't play audio CD's on G4 (woody)

On (29/04/03 17:25), Georg Koss wrote:
> On Tue, Apr 29, 2003 at 01:25:33PM +0000, Clive Menzies wrote:
> > >>When I try to play a CD using Xmms it can't seem to read
> > >>the Audio CD and suggests I make sure I have the requisite permissions
> > >>(which I have).
> > >
> > >Have you logged out and back in since you set the group ownership? Is
> > >/dev/hdc the correct device, or have you set it up for SCSI emulation?
> If I remember back I had some trouble with that group problem, adding
> myself with "vigr" to group sound. I tried a few times, at the end it
> just worked with "addgroup"  ( =8-o ). It was Woody around
> X-mas. Don't know why, but probably it might help ...

Thanks Georg but the group permissions seem fine - I can read data CD's - no problem 
> > Yes, I've actually rebooted a few times, as well (dual booting MacOSX). 
> >  I had read somewhere (TiBook doc but mine is a PowerMac) that generic 
> > scsi needs to be enabled in the kernel; so I checked that within 
> > menuconfig to be on the safe side.  Am I right in assuming that because 
> > I have nothing SCSI (as far as I am aware), I should now remove it?  
> You probably like to have CONFIG_BLK_DEV_SR and CONFIG_CHR_DEV_SR for
> CDROM and CD-RW ;) ( see kernel-help).

I had these set but as I don't have SCSI devices in my box I've just
recompiled without them (they didn't seem to be adding anything)

Since recompiling again (2.4.18 SMP) I seem to have progress of sorts.  When starting
KDE 3.1.1 I get the following errors:

New: "Error whilst initialising the sound driver"
      SNDCTL_DSP_SETFMT failed - invalid argument

(before it said /dev/dsp didn't exist)

kscd gives "CD ROM read or access error or no audio disc in drive"
  ... ensure permissions are correct etc....

(but I can access data CD's)

XMMS will show WAV file titles in its display which is new but
still won't play them (even without sound as far as I can tell)

However, for the first time ever, I am getting a faint beep for erroneous
keystrokes - so there is sound of sorts for the first time

Thanks Georg/Michel

I'd appreciate any further guidance you have to offer - would sending
dmesg output or other log help?



Reply to: