[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: airport on tibook: surfing vs. ssh/scp



On Sun, Feb 23, 2003 at 11:05:05AM -0500, christophe barbe wrote:
> On Sat, Feb 22, 2003 at 09:09:35AM -0800, Serge Rey wrote:
> > i tried this last night on my tibook. upgraded OS X and the airport
> > firmware went from 8.4 to 8.7.
> > 
> > however, booting back into linux i see the browsing problem with some
> > pages not loading still remains. (and the firmware is 8.7 according to
> > dmesg).
> 
> So if I understand correctly the remaining issue is the one I described.

yes, i think it is.
> 
> The best explanation I have found for this problem is related to MSS
> clamping [1]. This could explain why not everybody is seeing the
> problem. The symptoms are the same but it is difficult to explain why it
> occurs only when encryption is turned on. 
> 
> [1] http://home.earthlink.net/~jaymzh666/solaris/mss.html

great link. this lead me to poke around some more and one of the
suggestions i came across was to tweak the mtu setting. so here is what
i did

ifconfig eth1 mtu 462

and galeon is loading all the pages just fine now.

perhaps someone who knows networks better than i (which is a very large
population) could help explain why this setting seems to have done the
trick with the airport card. 

i should note that before this change, the default mtu assigned was 500.

-- 
Serge Rey	http://typhoon.sdsu.edu/rey.html
People who are aware of, and ashamed of, their prejudices are well on
the road to eliminating them.  -- Gordon Allport

Attachment: pgpY6JVBfBouW.pgp
Description: PGP signature


Reply to: