[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with Dual boot MacOSX/Woody - Yaboot on G4 Gigabit

On Monday, February 10, 2003, at 04:19  am, Chris Tillman wrote:

On Sun, Feb 09, 2003 at 11:25:08PM +0000, Clive Menzies wrote:


boot=/dev/hda2 (where Apple_Bootstrap resides)
brokenosx (added as a suggested fix but makes no difference)
macosx=hd:10 (where MacOS9.2 and MacOSX reside)

This is a typo, is it not? should be image=/vmlinux
Oops yes - a typo; it is correct in yaboot.conf


So, with this .conf, you get a menu with options OSX
or linux, right? l for linux loads yaboot. Is this where
the 'second stage bootstrap' error occurs?
No. It didn't get to a menu. On boot, it would get to a grey screen with "Loading second stage bootstrap..." and hang there

It really seems like this could be a ybin issue; or possibly
a filesystem corruption on the bootstrap partition, since
that's where it would be loading yaboot from. It may work
manually from OF through a different code path than the CHRP
script activation.

Try, first: ybin -v to see if any errors are reported.
I ran "/usr/sbin/ybin -b /dev/hda2 -v" and was asked if I wanted to create an HFS partition. I first answered No and it aborted; so I ran it again answering Yes and everything seemed to work fine - no errors reported.

Then mkofboot -v so the bootstrap partition filesystem is
I then ran "mkofboot -b /dev/hda2 -v" and that seemed to work fine.

I have progress of sorts in that it will now boot into OSX (without having to hold Option on start-up) but I still need OF (Cmd+Opt+O+F) to boot Linux. So I haven't, as yet, seen the yaboot menu in action ;-)



Reply to: