[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Fwd: failed install : bf 3.0.17 ppc (powermac)]

On Tue, Dec 04, 2001 at 11:17:06PM +0100, Fabrice Lorrain (home) wrote:
> Hi,
> I didn't get much answer in d-boot so I'm forwarding it here.
> Any idea ?
> 	Fab
> [no CC, thanks]
> Hi,
> I tried to install woody (bf 3.0.17) on a G4 this weekend.
> harware : G4, 400Mhz, 1Go RAM, 2 ide harddrives
> First try: using an USB floppy drive...
> Doesn't seem to be supported. Might be nice if it were
> written in the "woody install manual".

Nobody's tried it before, AFAIK. I'm not too surprised, those floppies
don't work very well even with MacOS, they have very special drivers.
I've added a note to the manual.
> 2nd try: network boot
> hmmm, boot enet doesn't work, some google search + reading,
> works with "boot enet:0" --> patch in "install manual" ?

got that one too.

> It seems I didn't find the right image to load through
> tftp (dhcp + tftp + logs + tcpdump everything was find)
> but I keep getting a freeze in openboot during the tftp.
> What image am I suppose to use?

linux from the powermac folder should be it
> 3rd try: yaboot
> Last just because I though a had only hfs+ partitions.
> Did some reading in d-powerpc, and I didn't get a clear
> picture about yaboot booting over hfs+. Is it supported
> or not ?

No, you can put your kernel on hfs+ but why would you want to... the
kernel can't read it.

> first boot, got the installation prompt, boot and ...
> "...ok
> copying OF device tree...done
> Calling quiesce...
> booting...
> _"
> ... the G4 is frozen (no response from the keyboard, the cdrom
> stop). After some tests I gave a try with mem=512M and it works.
> Seems to be a kernel bug here, but it might be nice if the solution
> were documented.

If you try it with append="video=ofonly" instead of mem=512M does it
work also?

> >From there, the first stage installation went pretty fluently, no
> logs on any tty. Reboot, but I wasn't able to log for the second
> stage install (some pam message, doesn't say much).

No info here we can work on

> Problems on the console during the boot:
> S20modutils, depmod -a seg fault on appletalk.o (bunch of Bad symbol).

Sounds like it would be a bug against the ipddp kernel module.

> reboot, boot through yaboot, mount /dev/hdbwhatever /target, chroot
> /target.
> base-config, answer a bunch of question (no tasksel, no dselect)
> everythg
> seems ok, but at the end base-config keep telling me that one
> package failed to install. Retry --> no. Leaving base-config give

you don't mention which package.

> me the following message on the console :
> "hostname --fqdn gave non-zero exit code 11"
> Now these are the logs in /var/log/installer.log (top to bottom)
> (side note 1: what are you guys using to read that f*** file ??)
> " base-config: line 42: 216 Seg fault apt-get clean"
>  (yeah, apt-get seg fault on whatever parameter)
> "Use of uninitialized value in substitution (s///) at 
> /usr/share/perl5/Debconf/Format/822.pm line 57"
> I got that message all over the log almost after each menu of
> base-config.
> After the ppp menu, I've the following line :
> base-config: 40apt-setup exit with return code 139.
> This is where I stand for so far ;-)
> Following a mail in d-powerpc I also move /etc/inittab.real over 
> /etc/inittab at some time yesterday.
> Any clue what's going on ?? Is it just me or the installation is
> completly broken ??

If someone shows interest you'll have to attach the whole log for it
to make any sense.
> Last remark, I didn't find fsck on the rescue disk. Any reason ?

e2fsck is there. 

*--v------ Installing Debian GNU/Linux 3.0 For PowerPC -----v----*
|  <http://mirrors.kernel.org/debian/dists/woody/main/disks-     |
|  (pause for breath)    powerpc/current/doc/install.en.html>    |
|         debian-imac: <http://debian-imac.sourceforge.net>      |
|            Chris Tillman        tillman@azstarnet.com          |
|                     May the Source be with you                 |

Reply to: