[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with XFree

On Tue, Dec 04, 2001 at 09:31:33PM -0800, Grant Bowman wrote:
> I used "dpkg-reconfigure xfree86-common" several times choosing
> different options but I couldn't get X to load.  I think it should work
> with even the simple setting of ati xserver and a 17" monitor.  Any
> suggestions on how to get around a "no screens found" error?  There's
> already a Section "Screen" in /etc/X11/XF86Config-4.  I've attached part
> of my /var/log/XFree.0.log file that I think is relevant.  If I should
> forward the whole thing, just let me know.
> Thanks,
> --
> -- Grant Bowman                                   <grantbow@svpal.org>

The attached XF86Config-4 works on my iMac. YMMV.

*--v------ Installing Debian GNU/Linux 3.0 For PowerPC -----v----*
|  <http://mirrors.kernel.org/debian/dists/woody/main/disks-     |
|  (pause for breath)    powerpc/current/doc/install.en.html>    |
|         debian-imac: <http://debian-imac.sourceforge.net>      |
|            Chris Tillman        tillman@azstarnet.com          |
|                     May the Source be with you                 |
# XF86Config-4 (XFree86 server configuration file) generated by Dexconf, the
# Debian X Configuration tool, using values from the debconf database.
# Edit this file with caution, and see the XF86Config manual page.
# (Type "man XF86Config" at the shell prompt.)

Section "Files"
	#FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	#FontPath	"/usr/lib/X11/fonts/cyrillic"
	#FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/75dpi"
	FontPath	"/usr/lib/X11/fonts/100dpi"

Section "ServerFlags"

Section "Module"
	Load	"ddc"
	Load	"GLcore"
	Load	"dbe"
	Load	"dri"
	Load	"extmod"
	Load	"glx"
	Load	"pex5"
	Load	"record"
	Load	"xie"
	Load	"bitmap"
	Load	"freetype"
	Load	"speedo"
	Load	"type1"
	Load	"vbe"
	Load	"int10"

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbDisable"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"macintosh"
	Option		"XkbLayout"	"us"

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"

Section "Device"
	Identifier	"Rage 128"
	Driver		"ati"
	Option		"UseFBDev"		"true"
        BusID                 "0:16:0"

Section "Monitor"
	Identifier	"iMac monitor"
	HorizSync	30-60
	VertRefresh	50-75
	Option		"DPMS"

Section "Screen"
	Identifier	"Default Screen"
	Device		"Rage 128"
	Monitor		"iMac monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		8
		Modes		"1024x768"
	SubSection "Display"
		Depth		15
		Modes		"1024x768"
	SubSection "Display"
		Depth		16
		Modes		"800x600" "1024x768"
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600"

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"

Section "DRI"
	Mode	0666

# end of XF86Config

Reply to: