[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

The 'startx' effort continues...

Thanks to all for advice so far...

Refresh on my computer: PowerMac 7600/120, internal CD-ROM, 16 MB memory, standard apple keyboard and mouse, standard ubiquitous 15" Mac monitor.

Installed latest Debian stable release 2.2 R3. Selected to install Gnome on installation. I did not use Dselect, just the simplified install. Been having troubles with Xwindows and Gnome.

The Command-Control-Delete (big delete button, not little one) got me out of X, so I could troubleshoot without rebooting.

Looking at the stderr from running 'startx', I got a whole bunch of messages, not of which screamed "error" to me. I had an unresolved dependency for the xie.so file. I didn't see the file anywhere on my computer.

I dove into the XF86Config file, and tried changing the mouse driver to "Auto" from "BusMouse". 'startx' failed with a "unable to identify mouse" message. Then I tried "PS/2", and was able to move the mouse upon entry into X. Yea!

The colors are horrific, due I assume to only 256 colors enabled on monitor. Went into MacOS, reset to thousands of colors (same 640 X 480 resolution), back into Linux, X burped with a type 11 error. I do not know how to reset in Linux to account for change in monitor colors. So back to 256.

Back into X, and all I have is the Main icon in upper left, and three icons on the right. The top right is an "about GnuStep" icon. The middle right fails to launch an Xterm. The bottom right is preferences.

That is all I get. Try double-clicking on Main, nothing happens. Since I haven't seen a correctly working X on a PowerPC, I don't know just how short I am of where I need to be. Ideas?

One thought. When I first installed, I accidentally named my computer "Pengguin", mispelling it. I went into the /etc/hostname file and changed it to "Penguin". Do I need to change other config files too? Some disconnect between Xclient and Xserver?


Mike Yukish
Head, Manufacturing Product & Process Design Department
Applied Research Lab/Penn State University
(814) 863-7143

Reply to: