[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: The 'startx' effort continues...

On Tue, 6 Nov 2001, Mike Yukish wrote:

> I dove into the XF86Config file, and tried changing the mouse driver to
> "Auto" from "BusMouse". 'startx' failed with a "unable to identify mouse"
> message. Then I tried "PS/2", and was able to move the mouse upon entry
> into X. Yea!

Why was it "BusMouse" in the first place?

> The colors are horrific, due I assume to only 256 colors enabled on
> monitor. Went into MacOS, reset to thousands of colors (same 640 X 480
> resolution), back into Linux, X burped with a type 11 error. I do not know
> how to reset in Linux to account for change in monitor colors. So back to 256.

Probably have to change the kernel command line in your boot loader, and
add a "DefaultColorDepth" (I assume you're using XFree 3.3.x, since you
say you're running Potato) line into the "Screen" section of your
XF86Config. I don't know what framebuffer your system uses, though, so
you'll have to find out what framebuffer driver you're using (run dmesg,
pipe it through less, and look for 'fb0', or cat /proc/fb).

> Back into X, and all I have is the Main icon in upper left, and three icons
> on the right. The top right is an "about GnuStep" icon. The middle right
> fails to launch an Xterm. The bottom right is preferences.

Window Maker, eh? Are you sure you have xterm, wterm, aterm or some other
terminal app installed? Does wmaker issue an error when you double-click
the dock icon to start a terminal?

> That is all I get. Try double-clicking on Main, nothing happens. Since I
> haven't seen a correctly working X on a PowerPC, I don't know just how
> short I am of where I need to be. Ideas?

Well, you're running a slightly different setup than I am. Both of the PPC
boxen I have that actually run X are NewWorld systems running XFree 4.1.0
(and both have Rage128s in them).

> One thought. When I first installed, I accidentally named my computer
> "Pengguin", mispelling it. I went into the /etc/hostname file and changed
> it to "Penguin". Do I need to change other config files too? Some
> disconnect between Xclient and Xserver?

Edit /etc/hosts, there should be a line there to associate your machine
with an IP address. Change the name there to match.

Derrik Pates      |   Sysadmin, Douglas School   |    #linuxOS on EFnet
dpates@dsdk12.net |     District (dsdk12.net)    |    #linuxOS on OPN

Reply to: